Bug 46456 - CultureInfo("ug-CN") not found in Xamarin.Android and Xamarin.iOS
Summary: CultureInfo("ug-CN") not found in Xamarin.Android and Xamarin.iOS
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2016-11-04 08:47 UTC by Mike
Modified: 2016-11-22 16:51 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Mike 2016-11-04 08:47:02 UTC
When I create CultureInfo ci = new CultureInfo("ug-CN") in Portable dll;  It will throw exception in Android and iOS.  But Windows these all fine,   it was in the System.Globalization assembly.

I think it would be very helpful if Xamarin could auto connect the windows culture to Android or iOS.
Comment 1 Marek Safar 2016-11-22 13:46:08 UTC
Fixed in master
Comment 2 Mike 2016-11-22 15:52:22 UTC
@Marek Safar, Is that a open source project? If yes, could you provide the link?
Comment 3 Marek Safar 2016-11-22 15:56:21 UTC
It's open source code, relevant commit https://github.com/mono/mono/commit/d0b9c5ebbb0424cc6482c4720957bb758860d2d2
Comment 4 Mike 2016-11-22 16:51:05 UTC
@Marek Safar, Thank you very much.  weird..., I thought Xamarin base class library is different than mono, because mono looks like support Duplex channel, but in xamarin still can't do it(for Android and iOS). https://bugzilla.xamarin.com/show_bug.cgi?id=41392

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.