Bug 46394 - Only mono source code is installed
Summary: Only mono source code is installed
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General (show other bugs)
Version: XI 9.99 (iOS 10 previews)
Hardware: PC Mac OS
: Low minor
Target Milestone: Future Cycle (TBD)
Assignee: Manuel de la Peña [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2016-11-03 16:59 UTC by Marek Safar
Modified: 2017-12-11 11:37 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Marek Safar 2016-11-03 16:59:30 UTC
Now when XI is open sourced it'd be useful to install also XI source (not only mono sources) so anyone can debug installed XI.
Comment 1 Manuel de la Peña [MSFT] 2017-01-25 17:12:50 UTC
Fix landed in master/d7a9bd462a02ca5251af308dd260ab63de4e28f8 and cycle9/2bcf787f0545d985d84c74c9c98cd7a55bd69d91
Comment 2 Manuel de la Peña [MSFT] 2017-01-30 11:44:57 UTC
Uh, sorry I confused when I did that comment, I'm working on it. Sorry.
Comment 3 Manuel de la Peña [MSFT] 2017-03-17 08:42:59 UTC
PR Present for the fix on https://github.com/xamarin/xamarin-macios/pull/1663 but we might want to wait until https://github.com/xamarin/xamarin-macios/pull/1872 when we move to pdbs.
Comment 4 Manuel de la Peña [MSFT] 2017-04-05 18:04:58 UTC
FYI I'm back on this since https://github.com/xamarin/xamarin-macios/pull/1872  was merged.
Comment 5 Manuel de la Peña [MSFT] 2017-12-11 11:37:38 UTC
Fixed in PR: https://github.com/xamarin/xamarin-macios/pull/1663

Users, if they have enabled the stepping into the framework, are able to step into both the Xamarin code and the mono code. All src files can be found under /Library/Frameworks/Xamarin.iOS/Versions/Current/src after the new packages are used.