Bug 46121 - [mlaunch] We do not show any error when launching on a device that isn't supported by currently selected Xcode
Summary: [mlaunch] We do not show any error when launching on a device that isn't supp...
Status: CONFIRMED
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools (show other bugs)
Version: master
Hardware: PC Mac OS
: Normal enhancement
Target Milestone: Future Cycle (TBD)
Assignee: Rolf Bjarne Kvinge [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2016-10-28 11:07 UTC by Vincent Dondain [MSFT]
Modified: 2017-06-15 09:03 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Vincent Dondain [MSFT] 2016-10-28 11:07:13 UTC
So if you try to run on let's say an iOS 10.1 device with Xcode8 selected in Xamarin Studio, you don't get any warning, error or whatsoever. The app is successfully installed but can't be launched, therefore the debugger is waiting endlessly, same for the profiler.

Xcode cannot run app on iOS devices that have a version it does not know of, nor show the simulators for versions above its maximum supported version. In our case we'd need Xcode8.1 to run the app on an iOS 10.1 device.

However Xcode show a very explicit alert window and does not even let you try to run the app: https://www.dropbox.com/s/5i9w67bfeyehm3s/Screenshot%202016-10-28%2012.47.51.png?dl=0

We'd need to have some mlaunch error and maybe fancier warnings in the IDE + profiler.

Note You need to log in before you can comment on or make changes to this bug.