Bug 46062 - Cannot create a WatchKit App (watchOS2) project
Summary: Cannot create a WatchKit App (watchOS2) project
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: watchOS add-in (show other bugs)
Version: 6.1.2 (C8SR1)
Hardware: Macintosh Mac OS
: High critical
Target Milestone: (C8SR1)
Assignee: Jeffrey Stedfast
URL:
: 45999 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-27 18:36 UTC by Manish Sinha
Modified: 2016-11-01 14:31 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: XS 6.1.2.3 (cycle8)


Attachments

Description Manish Sinha 2016-10-27 18:36:36 UTC
Install XS 6.2.0.1311

Steps to reproduce

1. Create an iOS app
2. Right click solution, Add New Project
3. Under watchOS click "WatchKit App"
4. Configure watch app
5. Click Next, then Finish

Expected: WatchKit app should be created successfully
Actual: WatchKit App creation throws an error

NSInvalidArgumentException: -[SimDevice pairedDevice]: unrecognized selector sent to instance 0x7fc94f87fde0

Closing the solution, shows this dialog
http://recordit.co/LbdlPjNqPU

Ide.log: http://xqa.blob.core.windows.net/gist/WatchOS2App.Ide.log.161027105035-aa7d595e249d486f9a84e26a1ca1f817.txt
XS Info: http://xqa.blob.core.windows.net/gist/log-4deca855fb2f4941bed21f5eb01f1399.txt
Comment 2 Manish Sinha 2016-10-28 13:52:17 UTC
Moved this to C8SR1 milestone, as this also happens on C8SR1
http://xqa.blob.core.windows.net/gist/WatchOS2App.Ide.log.161027225014-d16f3cb69990469ea3e36354d16575ec.txt

Jeff can, you cherry pick it on cycle8 branch
Comment 3 Manish Sinha 2016-10-28 13:55:12 UTC
I can verify that it is fixed on XS master 6.2.0.1314, still needs fix on cycle8
Comment 4 Manish Sinha 2016-10-28 13:57:24 UTC
*** Bug 45999 has been marked as a duplicate of this bug. ***
Comment 5 Mohit Kheterpal 2016-11-01 14:31:43 UTC
This issue has been fixed with latest build of Cycle 8 i.e. XS 6.1.0.5357 as shown in screencast : http://www.screencast.com/t/UgJDfE8TuJ

Hence closing this issue by marking it as Verified.

thanks

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 46062 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: