Bug 45901 - Missing .NET code pages ibm775 & ibm737
Summary: Missing .NET code pages ibm775 & ibm737
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: General (show other bugs)
Version: master
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Alexander Köplinger [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2016-10-25 22:17 UTC by Jo Shields
Modified: 2018-01-04 15:30 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jo Shields 2016-10-25 22:17:27 UTC
This seems like an oversight to me. 775 is DOS Baltic, 737 is DOS Greek. The DOS code pages are what get resolved on Linux when not set to UTF-8 everywhere, e.g. lt_LT. Seems to also affect Android?

Causes the issue described on https://forums.xamarin.com/discussion/61880/system-notsupportedexception-regarding-encoding
Comment 1 IdontLikeBugs 2016-10-25 22:27:35 UTC
Additional issue caused by this bug: 
Is it impossible to compile monodevelop from source.
Make command throws error:
The type initializer for 'PACKAGE_xxx' threw an exception.
  No data is available for encoding 775.

Workaround is to set a different locale, for example C:
LANG=C make

After that everything seems to be working.
Comment 4 Alexander Köplinger [MSFT] 2018-01-04 15:30:57 UTC
Fixed with https://github.com/mono/mono/pull/6361