Bug 45899 - [Xcode 8.1 GM] "error HE0035: Could not find a paired iPhone device for the Watch 'watchOS 3.1 (14S471a) - Apple Watch - 42mm' (C64439C5-9D9C-4B5C-B3B5-F77BBAA5B669)" when attempting to launch watch app on series1 sim
Summary: [Xcode 8.1 GM] "error HE0035: Could not find a paired iPhone device for the W...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: watchOS add-in (show other bugs)
Version: 6.1.1 (C8SR0)
Hardware: PC Mac OS
: Normal major
Target Milestone: (C8SR1)
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2016-10-25 19:47 UTC by Kyle White
Modified: 2016-11-01 19:50 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Kyle White 2016-10-25 19:47:38 UTC
[Xcode 8.1 GM] "error HE0035: Could not find a paired iPhone device for the Watch 'watchOS 3.1 (14S471a) - Apple Watch - 42mm' (C64439C5-9D9C-4B5C-B3B5-F77BBAA5B669)" when attempting to launch watch app on series1 sim


## Steps to repro

1. Create a new "iOS > App > Single View App (C#)" in Xamarin Studio.

2. Add a watch kit app to the solution 

2. Select the Debug configuration, select the watch start up project, and select an old *Series 1* watch

3. Select "Run > Start Debugging".


## Results

The deployment to the simulator fails due to no paired iPhone to the watch.

Application output: https://gist.github.com/kdubau/b0413f5b1dc39ec00d6f064369cd04b7


## Additional info 

About info and ide logs: https://gist.github.com/kdubau/6f35e5156a7ee593ab8864233cf2e1db
Comment 1 Manish Sinha 2016-10-25 20:40:36 UTC
I can confirm this issue with the product versions provided above.
Comment 2 Vincent Dondain [MSFT] 2016-10-25 23:38:16 UTC
Right this is because we list all watchOS simulators and don't ensure they all have a paired device.

By default Xcode does not pair the Apple Watch Series 1 - watchOS 3.1 simulators to anything (just the Series 2).

Workaround: in Xcode take any iPhone simulator and add it a Apple Watch Series 1 - watchOS 3.1 sim.
Comment 3 Sebastien Pouliot 2016-10-26 13:19:26 UTC
Q: Should we list unpaired phones ? does Xcode does ? and are they usable ?

A bit sad that we expose an `HExxxx` error (not an `MTxxxx` one) as it likely won't be easy to find any error documentation that we could provide to teach how to pair the simulators.
Comment 4 Jeffrey Stedfast 2016-10-26 14:38:25 UTC
This is fixed in master
Comment 5 Jeffrey Stedfast 2016-10-26 14:41:06 UTC
md-addins commit d5440d242bb0e663d18dc1d2019eb3ebbf842316
Comment 6 Mohit Kheterpal 2016-11-01 19:50:37 UTC
I have checked this issue and observed that this issue has been fixed with "ProductName": "Xamarin Studio",
    "InstallerUri": "https://bosstoragemirror.blob.core.windows.net/wrench/monodevelop-windows-cycle8/0c/0ccfcd52b95305ebd5b7eca0d88c1017035910ae/XamarinStudio-6.1.2.44.msi",
    "MD5": "c2b711a6de14b4dae1ebb529a7abcf17",
    "Length": 105279488

i.e. user is able to deploy app on apple watch simulator of series 1 using stable Xcode 8.1

Hence closing this issue by marking it as Verified.

thanks