Bug 45862 - [Xcode 8.1 GM] "May Slow Down Your iPhone ... The developer of this app needs to update it to improve its compatibility." because of default "i386" supported architecture setting in the iPhoneSimulator configuration on new projects
Summary: [Xcode 8.1 GM] "May Slow Down Your iPhone ... The developer of this app needs...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: 4.2.0 (C8)
Hardware: PC Mac OS
: --- normal
Target Milestone: 4.2.1 (C8SR1)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-25 01:54 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2016-11-01 08:27 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Brendan Zagaeski (Xamarin Team, assistant) 2016-10-25 01:54:39 UTC
[Xcode 8.1 GM] "May Slow Down Your iPhone ... The developer of this app needs to update it to improve its compatibility." because of default "i386" supported architecture setting in the iPhoneSimulator configuration on new projects




## Example manual fix for iPhoneSimulator (for users seeing this issue)

Change  "Project properties > iOS Build > Advanced [tab] > Supported architectures" to "x86_64" (instead of the default "i386") for the iPhoneSimulator configuration.

(In my tests, selecting "i386 + x86_64" was also acceptable.)




## Regression status: Upstream intentional change in Xcode 8.1 GM compared to Xcode 8.0

YES warning: Xcode 8.1 (11542), Build 8T61a 
NO  warning: Xcode 8.0 (11246), Build 8A218a




## Steps to replicate

1. Apply the "indelicate" workaround from Bug 45855, Comment 8 on the Mac to avoid that bug.

2. I also had to replace 2 other dynamic libraries in the Xcode.app bundle to avoid Bug 45676.  I won't bother to list the specifics because it will be better to verify this bug against a build that includes the real fix for Bug 45676 rather than my local hacks.

3. Create a new "Visual C# > iOS > iPhone > Single View App (iPhone)" project.

4. For the purposes of this bug, edit the `Info.plist` to select "iOS 9.3" as the "Deployment Target" (to avoid Bug 45859).

5. Select the Debug configuration, and select an iOS 10.1 simulator from the configuration menu.

6. If you have installed the same app on the simulator before, you'll probably need to do a "Simulator > Reset Content and Settings" to get the problematic alert as reported below.  (Note: You will also want to quit the simulator after resetting it to ensure that Xamarin will be able to deploy to it as expected.)

7. Select "Debug > Start Debugging".




## Results

An alert is displayed on the simulator when the application launches:

> "UnifiedSingleViewIphone1"
> May Slow Down Your iPhone
> The developer of this app needs to
> update it to improve its compatibility.



## Additional environment info (brief)



### Windows

Xamarin   4.2.1.15 (2ecdcdd)

Microsoft Visual Studio Enterprise 2015, 
Version 14.0.25425.01 Update 3

Windows 10, Version 1607 (OS Build 14393.187)



### Mac

Xamarin.iOS 10.0.2.3 (26328e0)
Mono 4.6.1 (mono-4.6.0-branch/2f4c98b) (64-bit)

Xcode 8.1 (11542), Build 8T61a
Mac OS X 10.11.6
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2016-10-25 01:55:42 UTC
I have filed this bug as a corresponding tracking bug for XVS to match the Xamarin Studio Bug 45861.
Comment 2 xamarin-release-manager 2016-10-25 19:16:53 UTC
Fixed in version 4.3.0.143 (master)

Author: Emanuel
Commit: d77e24a12dcd57372897a05bed24fd54d21c2fc7 (xamarin/XamarinVS)
Comment 3 xamarin-release-manager 2016-10-25 19:17:12 UTC
Fixed in version 4.2.1.32 (cycle8)

Author: Emanuel
Commit: 200dbb0ce4d6183d75f5c9b2ca16a0522621a1eb (xamarin/XamarinVS)
Comment 4 Shruti 2016-10-26 10:12:15 UTC
I have checked this issue and observed that this issue has been fixed on Cycle8-sr0. On creating iOS Project, default architecture is getting set as x86_64. Therefore, on deploying app , not getting any alert pop up of 'May Slow Down Your iPhone......'. 

Environment Info: https://gist.github.com/shrutis360/b078d44c1e98d118c0eafbf105a1e543

Screencast: http://www.screencast.com/t/xd6uK6fs0O

I will verify this issue once  master and Cycle8 builds are available to us.

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 45862 on Developer Community if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: