Bug 45856 - Missing iOS 10.0 deployment target
Summary: Missing iOS 10.0 deployment target
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: 6.1.1 (C8SR0)
Hardware: All All
: --- normal
Target Milestone: (C8SR1)
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2016-10-24 21:57 UTC by Ben Beckley
Modified: 2017-02-07 17:10 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Ben Beckley 2016-10-24 21:57:43 UTC
Hello, after installing Xcode 8.1 (8T61a) I noticed that there is no deployment target option for 10.0, but there is an option for it in Xcode.

XS: http://screencast.com/t/eWlywWuPZs
VS: http://screencast.com/t/2snTht4OvuR

XS info: https://gist.github.com/BenBeckley/342935837f087804dc274054c030d0f1
VS info: https://gist.github.com/BenBeckley/8ac869b1aef710f7758125f204c6aa4b
Comment 1 Vincent Dondain [MSFT] 2016-10-24 23:29:55 UTC

*** This bug has been marked as a duplicate of bug 45855 ***
Comment 2 Vincent Dondain [MSFT] 2016-10-24 23:57:09 UTC
Oops no sorry this is *not* a duplicate. I can confirm the bug.
Comment 4 xamarin-release-manager 2016-10-25 00:50:48 UTC
Fixed in version 6.2.0.1275 (master)

Author: Vincent Dondain
Commit: 078415749e06d6862ebc56d888da177d3ca01ec7 (xamarin/md-addins)
Included in Commit: ff21abf0957394de3edb5647738c96fe4aa1f268 (mono/monodevelop)
Comment 5 Shruti 2016-10-26 09:51:36 UTC
I have checked this issue with C8SR0 builds of XS 6.1.1.17 and XVS Xamarin.VisualStudio_4.2.0.713 & could see 10.0 and watchOS 3.0 versions in deployment target of projects.

XS Screencast: http://www.screencast.com/t/qYG04WXypRmp
XVS Screencast: http://www.screencast.com/t/DcfqnWCJ


I will close this issue once we get the builds and able to verify on master & C8SR1.
Comment 6 Shruti 2016-10-27 12:16:42 UTC
This issue is working fine on master XS 6.2 (build 1309. Default architecture is getting set as x86_64 and  could see 10.0 and watchOS 3.0 versions in deployment target of projects.

Build Information
Release ID: 602001309
Git revision: 3b3e057a1d1404e9c7c1a4fb99fee0c089639c2c
Build date: 2016-10-27 03:47:05-04
Xamarin addins: a432850dbcb364b79b85d12f3cf0d673ac0a9f48
Build lane: monodevelop-lion-master


Please fix the commit on C8/C8SR1 lane so that I could verify this issue.
Comment 7 xamarin-release-manager 2016-10-27 20:57:28 UTC
Fixed in version 6.1.2.43 (cycle8)

Author: Vincent Dondain
Commit: 498052646a071056915eddac382f29ec4eea42bf (xamarin/maciostools)
Included in Commit: c456910b8ff4c2ee2835bd5919a62a5f76a0e564 (mono/monodevelop)
Comment 8 Shruti 2016-10-28 10:59:10 UTC
This issue is working fine on Cycle8 XS 6.1.2 (build 43). Default architecture is getting set as x86_64 and  could see 10.0 and watchOS 3.0 versions in deployment target of projects.


Build Information
Xamarin Studio Version 6.1.2 (build 43)
Release ID: 601020043
Git revision: c456910b8ff4c2ee2835bd5919a62a5f76a0e564
Build date: 2016-10-27 18:51:17-04
Xamarin addins: b0031913252c96f946dadea74305d7126b5fe979
Build lane: monodevelop-lion-cycle8
Comment 9 xamarin-release-manager 2017-02-07 17:10:12 UTC
Fixed in version 6.1.5.3 (cycle8-mlaunch-xcode83-fix)

Author: Vincent Dondain
Commit: a0f3ca4edd6582b44e053de4c220cc6ddd5f92bb (xamarin/maciostools)
Included in Commit: 776f2e6f2c16460204aa92f566caacf2da49259c (mono/monodevelop)