Bug 45719 - [Cycle 9] Xamarin.VisualStudio .msi installer has increased to roughly 165% of its previous size
Summary: [Cycle 9] Xamarin.VisualStudio .msi installer has increased to roughly 165% o...
Status: RESOLVED NOT_ON_ROADMAP
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Installer (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: High major
Target Milestone: Future Cycle
Assignee: Jose Gallardo
URL:
: 45381 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-19 22:02 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2017-10-06 01:28 UTC (History)
7 users (show)

Tags: Cycle9KI BZC9S1_C8SR2S1 ExPT xamexttriage
Is this bug a regression?: Yes
Last known good build: Cycle 8 SR 2

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_ON_ROADMAP

Description Brendan Zagaeski (Xamarin Team, assistant) 2016-10-19 22:02:50 UTC Comment hidden (obsolete)
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2016-10-19 22:14:35 UTC Comment hidden (obsolete)
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2016-11-01 20:44:28 UTC Comment hidden (obsolete)
Comment 6 Brendan Zagaeski (Xamarin Team, assistant) 2017-02-17 03:17:07 UTC
[Cycle 9] Xamarin.VisualStudio .msi installer has increased to roughly 165% of its previous size

(I am updating the description of this bug to reflect the latest information for Cycle 9 because this change will soon be moving into the Stable updater channel for the first time.)




## 165% installer size increase

449 MB - Xamarin.VisualStudio_4.2.2.11.msi
751 MB - Xamarin.VisualStudio_4.3.0.738.msi

(An increase of 302 MB.)




## Installation size (on a system with VS 2015 Update 3 as the only installed version of VS)

2.46 GB - Xamarin.VisualStudio_4.2.2.11.msi
3.20 GB - Xamarin.VisualStudio_4.3.0.738.msi

(An increase of 740 MB.  Keep in mind that 302 MB of that increase is simply due to the larger installer .msi that is cached in C:\Windows\Installer.  Also note that version 4.3 includes new features compared to version 4.2.)




## Background information

According to some preliminary discussion with the team, a significant fraction of this change in size seems to be due to new in-depth code signing strategies that have been added for the files in the Cycle 9 installer.  The installer had been using some de-duplication techniques that will need to be reworked to account for the new unique signatures on the files.
Comment 7 Pierce Boggan [MSFT] 2017-10-06 01:28:41 UTC
We won't be making any additional enhancements to the Visual Studio 2015 installer beyond updating the payload with the latest bits.

Resolving as not on roadmap.