Bug 45676 - Cannot launch app on iOS 10.1 simulator (Xcode8.1)
Summary: Cannot launch app on iOS 10.1 simulator (Xcode8.1)
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: 4.2.0 (C8)
Hardware: PC Windows
: High major
Target Milestone: 4.2.1 (C8SR1)
Assignee: Emanuel
URL:
Depends on:
Blocks:
 
Reported: 2016-10-18 22:49 UTC by Kyle White
Modified: 2016-11-08 22:40 UTC (History)
10 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
verbose zip logs (22.86 KB, application/x-zip-compressed)
2016-10-18 22:49 UTC, Kyle White
Details

Description Kyle White 2016-10-18 22:49:13 UTC
Created attachment 18113 [details]
verbose zip logs

Simple repo:
1) Set everything to use Xcode8.1 beta 3
2) Create an iOS app
3) try to launch it on the 10.1 simulator

Xamarin   4.2.1.15 (2ecdcdd)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.iOS   10.0.2.3 (26328e0)
Visual Studio extension to enable development for Xamarin.iOS.


Output is:

Launching 'App9' on 'iPhone 5 iOS 10.1'...
The app has been terminated.
Launch failed. The app 'App9' could not be launched on 'iPhone 5 iOS 10.1'. Error: error MT1008: Failed to launch the simulator: Could not load the framework 'libswiftAppKit.dylib' (path: /Applications/Xcode-beta.app/Contents/Frameworks/libswiftAppKit.dylib): dlopen(/Applications/Xcode-beta.app/Contents/Frameworks/libswiftAppKit.dylib, 1): Library not loaded: @rpath/libswiftQuartzCore.dylib
  Referenced from: /Applications/Xcode-beta.app/Contents/Frameworks/libswiftAppKit.dylib
  Reason: image not found
. Please check the logs for more details.
The app has been terminated.
Comment 1 Kyle White 2016-10-18 22:50:33 UTC
Xcode 8 with the same builds works as expected.
Comment 2 Kyle White 2016-10-19 00:06:52 UTC
FWIW, libswiftQuartzCore.dylib is definitely present in the Xcode-beta.app bundle on my mac host
Comment 3 Oleg Demchenko 2016-10-19 03:26:28 UTC
Getting the same issue with XVS 4.2.1.15
Comment 6 Mohit Kheterpal 2016-10-26 14:17:57 UTC
I have checked this issue with latest build of Xcode 8.1 and observed that now we are able to deploy iOS application on simulator.

Environment info : 
=== Xamarin Studio Enterprise ===

Version 6.1.1 (build 17)
Installation UUID: fd96f29c-8917-44db-ad82-5331551e9d03
Runtime:
	Mono 4.6.1 (mono-4.6.0-branch-c8sr0/ef43c15) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 406010005

=== NuGet ===

Version: 3.4.3.0

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 8.1 (11542)
Build 8T61a

=== Xamarin.iOS ===

Version: 10.2.0.4 (Xamarin Enterprise)
Hash: b638977
Branch: xcode8.1
Build date: 2016-10-25 14:38:48-0400

=== Xamarin.Android ===

Version: 7.0.1.3 (Xamarin Enterprise)
Android SDK: /Users/xamarin77/Desktop/android-sdk-macosx_êèéæâàçéè€ÿëïœ_a
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)
		7.0    (API level 24)

SDK Tools Version: 25.2.2
SDK Platform Tools Version: 24.0.3
SDK Build Tools Version: 24.0.3

Java SDK: /usr
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.10.0.105 (Xamarin Enterprise)

=== Build Information ===

Release ID: 601010017
Git revision: 44d481a9be9cf2bf7c01bfb99c59b77dfa08e712
Build date: 2016-10-25 14:27:24-04
Xamarin addins: 19cdb28081bf28d9688698030abb96e04e391f69
Build lane: monodevelop-lion-cycle8-sr0

=== Operating System ===

Mac OS X 10.12.0
Darwin Xamarin77Macmini.local 16.0.0 Darwin Kernel Version 16.0.0
    Mon Aug 29 17:56:20 PDT 2016
    root:xnu-3789.1.32~3/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Gist Ide Information 1.0.2
Addin Maker 1.3.2
NuGet Package Management Extensions 0.11.1
Manifest.addin 0.0.0.0
Comment 7 Brendan Zagaeski (Xamarin Support) 2016-10-26 17:45:52 UTC
I am resetting the verification status back to "Resolved" on this bug for re-verification because the version info in Comment 6 only mentions Xamarin Studio.  But this behavior only happens in Visual Studio.

Thanks!
Comment 8 Mohit Kheterpal 2016-10-26 20:05:52 UTC
This issue is also working fine with XVS build 4.2.0.713 i.e. application is deploy and launch successfully on device and simulator of iOS 10.1

Hence closing this issue by marking it as Verified fixed.

thanks
Comment 9 Shruti 2016-10-27 06:07:15 UTC
I'll resetting the bug status as "resolved-Fixed" to track the completion of those merges against the current target milestone of this bug (C8SR1). 

Many Thanks!
Comment 10 Saurabh 2016-10-28 11:45:07 UTC
I have checked this Issue with latest XVS 4.2.1.0 and XI 10.2.1.0. Application getting launched on iOS Simulator 10.1 with Xcode 8.1

Debug Output: https://gist.github.com/saurabh360/4302362bde51716a865f6444714101db

Environment Info:
Microsoft Visual Studio Professional 2013
Version 12.0.40629.00 Update 5
Microsoft .NET Framework
Version 4.6.01532

Xamarin   4.2.1.40 (5a6de94)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.0.2.28 (d3dc82d)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.2.1.0 (295da87)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 11 ye_he 2016-11-08 22:29:28 UTC
Hi, guys.
I am still having this issue on the latest visual studio. Same error messages as the first post here. I was linked here from https://releases.xamarin.com/2016/10/ where a workaround was mentioned. But my question is "Where is the workaround"? I've read through the posts but still didn't know how I could deploy to iOS.
Comment 12 Brendan Zagaeski (Xamarin Support) 2016-11-08 22:40:29 UTC
@yehe01, I would recommend filing a new bug report that includes your full version details from both the Windows and Mac computers as well as the full exact error message you are seeing.

(In case it's helpful to know, new bug reports are encouraged by default because comments on "verified fixed" bugs aren't as visible to the engineering team for prioritization as new bug reports.  Thanks much!)



> "Where is the workaround"?

I see a mention of a workaround for a different bug on releases.xamarin.com, but not this exact Bug 45676.  The intended way to resolve the exact symptoms of this Bug 45676 (assuming Xcode 8.1, Build version 8B62 is installed on the Mac) is to update to https://releases.xamarin.com/stable-release-cycle-8-service-release-0-w-xcode8-1-support/ or newer on both the Windows and Mac computers.

For further investigation of an environment where that intended resolution is not working, please file a new bug report.  Thanks in advance!

Note You need to log in before you can comment on or make changes to this bug.