Bug 45644 - [iOS Designer] Accessing Designer throws error "Unable to boot device because it cannot be located on disk"
Summary: [iOS Designer] Accessing Designer throws error "Unable to boot device because...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS Designer (show other bugs)
Version: 6.1.1 (C8SR0)
Hardware: Macintosh Mac OS
: High major
Target Milestone: (C8SR1)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-18 16:25 UTC by Anubhav Ranjan
Modified: 2016-10-28 07:05 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Anubhav Ranjan 2016-10-18 16:25:18 UTC
Accessing iOS Designer raises error: (Error Domain=com.apple.CoreSimulator.SimError Code=163 "Unable to boot
device because it cannot be located on disk." )

[2016-10-17 08:17:34.0] INFO:     Description for NSError: Error Domain=com.apple.CoreSimulator.SimError Code=163 "Unable to boot device because it cannot be located on disk." UserInfo={NSLocalizedFailureReason=The device's data is no longer present at /Users/leenicaise/Library/Caches/Xamarin/iOSDesigner/B5078432-EE48-4D01-9F87-3070BD5EA846/data., NSLocalizedRecoverySuggestion=Use the device manager in Xcode or the simctl command line tool to either delete the device properly or erase contents and settings., NSLocalizedDescription=Unable to boot device because it cannot be located on disk.}


However, Simulator works just fine.


#Description:
I have a problem accessing the designer in Xamarin studio on my mac.

I wanted a clean new install of Xamarin and Xcode, so I removed both apps
and deleted all folders relating to them. (I was hoping to reclaim some
space on unnecessary files).
I then reinstalled Xcode and then installed Xamarin.

However, when I try to access the storyboard designer from any project, I
receive an error saying that it cannot find the simulator. I've attached
the log output.
(Error Domain=com.apple.CoreSimulator.SimError Code=163 "Unable to boot
device because it cannot be located on disk." )
Note - I can still run the app on the simulator.

I've removed all devices from the Devices window in xcode and I've also
removed them all in the terminal using simctl.


#Logs:
=====
https://dl.dropboxusercontent.com/u/30949500/Xamarin%20Samples/Logs_377554.zip

#Version:
========
Xamarin Studio 6.1.1
Xcode 8.0 (8A218a)
Comment 2 Anubhav Ranjan 2016-10-19 08:36:08 UTC
#Version Info:
===========
=== Xamarin Studio Business ===

Version 6.1.1 (build 15)
Installation UUID: 7b233faa-f941-4f2f-8706-7712d9af1c6f
Runtime:
Mono 4.6.1 (mono-4.6.0-branch-c8sr0/abb06f1) (64-bit)
GTK+ 2.24.23 (Raleigh theme)

Package version: 406010003

=== NuGet ===

Version: 3.4.3.0

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 8.0 (11246)
Build 8A218a

=== Xamarin.iOS ===

Version: 10.0.1.8 (Xamarin Business)
Hash: 3983064
Branch: cycle8-sr0-xi
Build date: 2016-09-23 15:34:54-0400

=== Xamarin.Android ===

Version: 7.0.0.18 (Xamarin Business)
Android SDK: /Users/leenicaise/Library/Developer/Xamarin/android-sdk-macosx
Supported Android versions:
6.0 (API level 23)

SDK Tools Version: 25.1.2
SDK Platform Tools Version: 24.0.0
SDK Build Tools Version: 23.0.2

Java SDK: /usr
java version "1.8.0_73"
Java(TM) SE Runtime Environment (build 1.8.0_73-b02)
Java HotSpot(TM) 64-Bit Server VM (build 25.73-b02, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Not Installed

=== Xamarin.Mac ===

Version: 2.10.0.103 (Xamarin Business)

=== Build Information ===

Release ID: 601010015
Git revision: fa52f02641726146e2589ed86ec4097fbe101888
Build date: 2016-09-22 08:03:02-04
Xamarin addins: 75d65712af93d54dc39ae4c42b21dfa574859fd6
Build lane: monodevelop-lion-cycle8-sr0

=== Operating System ===

Mac OS X 10.11.6
Darwin Lees-MacBook-Air.local 15.6.0 Darwin Kernel Version 15.6.0
Mon Aug 29 20:21:34 PDT 2016
root:xnu-3248.60.11~1/RELEASE_X86_64 x86_64
Comment 3 xamarin-release-manager 2016-10-19 20:16:26 UTC
Fixed in version 6.2.0.1253 (master)

Author: Alan McGovern
Commit: 84e15072d0fa858a0a071ceefea4915fa0818b79 (xamarin/md-addins)
Included in Commit: f7c8b6586cf27c343c3e2f550e787721b0b30082 (mono/monodevelop)
Comment 4 Alan McGovern 2016-10-20 16:57:45 UTC
Repro steps for QA:

Delete everything in the cache directory by running this in a terminal:
`$ rm -rf ~/Library/Caches/Xamarin/iOSDesigner/`

Try to start the designer. With some versions of Xcode it will fail, with others it will recover. I don't know which unfortunately. After the patch we will always recover.
Comment 5 Shruti 2016-10-24 12:41:49 UTC
************************
Reproduce Status:
************************

I am successfully able to reproduce this issue at my end; following by the comment0, comment2 and comment4. 

INFO:  Description for NSError: Error Domain=com.apple.CoreSimulator.SimError Code=163 "Unable to boot device because it cannot be located on disk." UserInfo={NSLocalizedFailureReason=The device's data is no longer present at /Users/nischal/Library/Caches/Xamarin/iOSDesigner/3E9DA162-3306-47EC-9C08-EBBB3D5A105E/data., NSLocalizedRecoverySuggestion=Use the device manager in Xcode or the simctl command line tool to either delete the device properly or erase contents and settings., NSLocalizedDescription=Unable to boot device because it cannot be located on disk.}
[2016-10-24 17:18:04.7] ERROR: EnsureSession (counter 1): System.AggregateException: One or more errors occurred. ---> Foundation.NSErrorException: Exception of type 'Foundation.NSErrorException' was thrown.
  at MonoTouch.Hosting.CoreSimulatorFullSession.StartImpl () [0x00134] in /Users/builder/data/lanes/3816/fa52f026/source/md-addins/Xamarin.Designer.iOS/external/ios-sim-sharp/MonoTouch.Hosting/CoreSimulatorFullSession.cs:203

Supplement Info:
iOS_Designer_Log:
https://gist.github.com/Shruti360/85a3e085a562967490e744247538dbd8

Environment Info and IDE Logs:
https://gist.github.com/shrutis360/cdc6d25c848ffa823f2ecaea883ec429

@Alan, I have checked that builds are failed on wrench, So unable to verify this issue for now. Could you please have a look to wrench issue.


Thanks!
Comment 6 Alan McGovern 2016-10-25 09:26:38 UTC
I have no idea when we'll be able to get builds. There are still some issues after migrating the bots
Comment 7 Shruti 2016-10-27 13:07:48 UTC
************************
Verification Status:
************************

I have checked this issue with Latest Master Build Of 
XamarinStudio-6.2.0.1310_05102fd27c6aa0b10dfd848f1a0d060885b7911e
and observe that this issue is fixed and work fine.

Supplement Info:
IDE Log:
https://gist.github.com/Shruti360/f4fa7a70a444c745177b448201d9641d

Environment Info:
https://gist.github.com/shrutis360/738a94156367ced8686fd9862c4b6297


Please! merge the commit in C8/C8SR1 so that we  can verify this issue on the same and close this issue.

Thanks!
Comment 8 xamarin-release-manager 2016-10-27 16:30:47 UTC
Fixed in version 6.1.2.39 (cycle8)

Author: Alan McGovern
Commit: 8431fc5048d3ce573f75fc9c1ba34424cce22f61 (xamarin/md-addins)
Included in Commit: af9f84a329b6510aa7e85bbc41b2e136063badb7 (mono/monodevelop)
Comment 9 Shruti 2016-10-28 07:05:53 UTC
I have checked this issue with latest C8 build of 
XamarinStudio-6.1.2.43_c456910b8ff4c2ee2835bd5919a62a5f76a0e564
and observe that this issue is fixed.

Supplement Info:
Environment Info, IDE Log, iOS_Designer Log:
https://gist.github.com/sachins360/16ae4a5fe1eb154bd20642adefef2fba

Hence, marking this issue as verified fixed.

Thanks!!