Bug 45544 - Native crash without stack trace.
Summary: Native crash without stack trace.
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Runtime
Classification: Mono
Component: GC (show other bugs)
Version: 4.6.0 (C8)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 45546 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-17 09:37 UTC by Mikhail Filippov
Modified: 2017-10-11 21:54 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
thread dump (106.50 KB, text/plain)
2016-10-17 09:37 UTC, Mikhail Filippov
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Mikhail Filippov 2016-10-17 09:37:18 UTC
Created attachment 18060 [details]
thread dump

I have native crash in mono. See attach for thread dump.

Stacktrace:


Native stacktrace:


Debug info from gdb:

(lldb) command source -s 0 '/tmp/mono-gdb-commands.uYYL37'
Executing commands in '/tmp/mono-gdb-commands.uYYL37'.
(lldb) process attach --pid 1291
2016-10-15 05:03:27.121 lldb[2344:1277254] Metadata.framework [Error]: couldn't get the client port
Process 1291 stopped
* thread #1: tid = 0x1313d0, 0x000000010f77dd4f, name = 'tid_a13', queue = 'com.apple.main-thread', stop reason = signal SIGSTOP
    frame #0: 0x000000010f77dd4f
->  0x10f77dd4f: lock   
    0x10f77dd50: cmpxchgl %r15d, (%r14)
    0x10f77dd54: movq   %rax, %r12
    0x10f77dd57: testl  %eax, %eax
Comment 1 Vlad Brezae 2016-10-27 20:05:09 UTC
Does this happen on the same project as https://bugzilla.xamarin.com/show_bug.cgi?id=44970, if so it's very likely to be the same issue ?
Comment 2 Vlad Brezae 2016-10-27 20:14:45 UTC
*** Bug 45546 has been marked as a duplicate of this bug. ***
Comment 3 Mikhail Filippov 2016-10-27 21:39:00 UTC
Maybe it is the same issue. Can you give me a link to commit or PR for the fix for this issue?
Comment 4 Vlad Brezae 2016-10-27 21:46:03 UTC
One potential cause that is already fixed on master, will also get fixed on 4.6 by https://github.com/mono/mono/pull/3833

There is also another suspect cause which will be addressed by https://github.com/mono/mono/pull/3764. Bear in mind that I don't think this PR works yet and it is a work in progress.
Comment 5 Rodrigo Kumpera 2017-10-11 17:39:27 UTC
Do you experience this bug on a recent (5.8+) version of mono?
Comment 6 Mikhail Filippov 2017-10-11 21:54:04 UTC
I can't see this crashes after migrate to 5.2