Bug 45289 - [UWP] Rotating Map Crashes App
Summary: [UWP] Rotating Map Crashes App
Status: RESOLVED DUPLICATE of bug 41900
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 2.3.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-11 20:13 UTC by Jimmy [MSFT]
Modified: 2016-12-06 16:36 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 41900

Description Jimmy [MSFT] 2016-10-11 20:13:05 UTC
### Overview
A customer is reporting a crash on UWP when rotating a map. The app crashes with:

{Windows.UI.Xaml.UnhandledExceptionEventArgs}
Exception: {"Value does not fall within the expected range."}
Handled: false
Message: "Value does not fall within the expected range."

They are able to reproduce with the Working with Maps sample, but I was not able to. My test device is running a newer version of Win10 Mobile however I don't know if this is affecting it.


### Steps to Reproduce
1. Run the UWP project from the "Working with Maps" sample: https://developer.xamarin.com/samples/xamarin-forms/WorkingWithMaps/
2. Rotate the device


### My Device Info
Device: Lumia 950
OS Build: 10.0.14936.1000


### Customer Device Info
Device: Lumia 650
OS Build: 10.0.14393.189
Comment 1 Samantha Houts [MSFT] 2016-10-19 18:31:53 UTC

*** This bug has been marked as a duplicate of bug 41900 ***