Bug 45284 - Extra tab icons display in iOS when binding Title on TabbedPage
Summary: Extra tab icons display in iOS when binding Title on TabbedPage
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.3.2
Hardware: All All
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL: https://github.com/xamarin/Xamarin.Fo...
Depends on:
Blocks:
 
Reported: 2016-10-11 17:27 UTC by Chad Kimes
Modified: 2017-02-17 10:52 UTC (History)
5 users (show)

See Also:
Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Extra icon on TabbedPage in iOS 10 (13.73 KB, image/png)
2016-10-11 17:27 UTC, Chad Kimes
Details

Description Chad Kimes 2016-10-11 17:27:00 UTC
Created attachment 17983 [details]
Extra icon on TabbedPage in iOS 10

This is due to a bug in iOS 10, more information available here:

http://stackoverflow.com/questions/38776978/ios-10-uitabbar-more-items-visible-after-setting-title

If the "Title" property is changed on an item in a TabbedPage, it updates the Title property on the TabBarItem (see https://github.com/xamarin/Xamarin.Forms/blob/master/Xamarin.Forms.Platform.iOS/Renderers/TabbedRenderer.cs#L188). This causes an additional icon to display (see attachment). Since the Title property is changed during binding, this means you can't bind the ItemsSource for a TabbedPage without seeing this extra icon.
Comment 1 Chad Kimes 2016-10-11 17:28:39 UTC
For historic purposes, here's the commit specific link where I think the bug is (instead of tracking master):

https://github.com/xamarin/Xamarin.Forms/blob/d5f4aeb4745e0b1e171275b7311b9e7a8d98d02d/Xamarin.Forms.Platform.iOS/Renderers/TabbedRenderer.cs#L188
Comment 2 adrianknight89 2016-10-22 17:03:08 UTC
There is a PR for this: https://github.com/xamarin/Xamarin.Forms/pull/448
Comment 3 Rui Marinho 2016-10-25 14:05:18 UTC
Isn't this iOS10 beta bug ? I can't reproduce this issue in current iOS10 version.

Here's my reproduction code:

https://gist.github.com/rmarinho/a31d52621f080095030e765490adbaba
Comment 4 Chad Kimes 2016-10-27 15:18:59 UTC
I can see it on my simulator and on a real device both running release versions of iOS 10, so it's not just a beta bug.

I have provided a minimal repro on the linked PR. The important thing seems to be changing out the collection that ItemsSource is bound to.
Comment 5 Stephane Delcroix 2017-01-26 10:07:40 UTC
new PR https://github.com/xamarin/Xamarin.Forms/pull/720
Comment 6 Rui Marinho 2017-02-17 10:52:21 UTC
Should be fixed in 2.3.5-pre1

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.