Bug 45255 - [WinRT] Back Button Not Visible If Current Page Does Not Have a Title
Summary: [WinRT] Back Button Not Visible If Current Page Does Not Have a Title
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 2.3.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 49976 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-10 21:11 UTC by Jimmy [MSFT]
Modified: 2016-12-30 20:49 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
repro project (115.69 KB, application/zip)
2016-10-10 21:11 UTC, Jimmy [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jimmy [MSFT] 2016-10-10 21:11:13 UTC
Created attachment 17967 [details]
repro project

### Overview
On Windows 8.1 apps, the navigation bar and back button will not be visible if the current page does not have its Title set. Prior to Forms 2.3.3-pre2, the navigation bar was visible regardless of the Title. This change in behavior is being caused by: 

https://github.com/xamarin/Xamarin.Forms/blob/master/Xamarin.Forms.Platform.WinRT/NavigationPageRenderer.cs#L498


### Steps to Reproduce
1. Run the attached Win8.1 project
2. Click the button to go to a another page


### Expected Results
The back button will be visible at the top of the page. You can uncomment line 15 in TestPage.cs to see the expected result.


### Actual Results
No back button is visible.


### Testing Info
Tested with Forms 2.3.3-pre2
Comment 1 Jimmy [MSFT] 2016-10-10 21:13:40 UTC
PR: https://github.com/xamarin/Xamarin.Forms/pull/438
Comment 2 Samantha Houts [MSFT] 2016-10-20 20:00:12 UTC
Should be fixed in 2.3.4-pre1. Thank you!
Comment 3 Parmendra Kumar 2016-11-25 10:17:06 UTC
I have checked this issue with Xamarin.Forms 2.3.4-pre1 and this issue is working fine.


Hence closing this issue.
Comment 4 Samantha Houts [MSFT] 2016-12-30 20:49:57 UTC
*** Bug 49976 has been marked as a duplicate of this bug. ***