Bug 45178 - ProgressBarRenderer can crash in native.
Summary: ProgressBarRenderer can crash in native.
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.1.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-07 15:22 UTC by Owen Pellegrin
Modified: 2016-12-02 15:40 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Call stack for one of the crashes. (2.38 KB, text/plain)
2016-10-07 15:22 UTC, Owen Pellegrin
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Owen Pellegrin 2016-10-07 15:22:15 UTC
Created attachment 17935 [details]
Call stack for one of the crashes.

A few months ago, we had a fairly consistent crash on one of our pages that downloads many files. At the time, we were using Xamarin Forms 1.5, so we held off investigation since we were planning on an update to 2.x.

That upgrade happened, and now we're on 2.1.0. The crash has reappeared. The call stack (attached) suggests the renderer gets confused and holds on to a reference to a widget that's gone. I haven't been able to reproduce it myself, but a remote QA team member has seen it several times on an iPad Air 2.
Comment 1 adrianknight89 2016-10-10 21:33:16 UTC
See https://github.com/xamarin/Xamarin.Forms/pull/439
Comment 2 Samantha Houts [MSFT] 2016-10-20 20:02:41 UTC
Should be fixed in 2.3.4-pre1. Thank you!