Bug 45173 - Cycle 8-specific "could not AOT the assembly"
Summary: Cycle 8-specific "could not AOT the assembly"
Status: RESOLVED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler (show other bugs)
Version: 7.0 (C8)
Hardware: PC Mac OS
: Normal major
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2016-10-07 14:57 UTC by Owen Pellegrin
Modified: 2017-10-13 17:45 UTC (History)
9 users (show)

Tags: XATriaged, bb
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Owen Pellegrin 2016-10-07 14:57:08 UTC
Our project uses a NuGet package we publish internally to access a native geospatial library. We use the <AotAssemblies> tag to enable AOT compilation, as we have found it provides significant performance improvements to our project.

When I compile and deploy with Xamarin Studio 6.1.1 and Xamarin.Android 7.0.1.3, packaging fails with the error message "error XA3001: Could not AOT the assembly: obj/Release/android/assets/<our_library>.dll". I've tested downgrading to Xamarin Studio 6.0.2 and Xamarin.Android 6.1.2, and that version is able to AOT the assembly. Other team members who have updated their Windows installations to the most current versions are also experiencing this problem.

There doesn't seem to be any more information available, the build log's line before the error is emitted just basically says it's trying to AOT. Previous versions of Xamarin are able to AOT the assembly, and it hasn't changed in the past month, so it seems to be a problem with the Xamarin AOT compiler.
Comment 1 Kirill 2016-11-02 18:10:19 UTC
I have same problem. I don't get other logs except "Could not AOT the assembly"
Comment 2 Al Clark [MSFT] 2017-06-28 21:57:34 UTC
Does the problem present on the latest Visual Studio for Mac?
Have you tried deleting your 'obj' and 'bin' folders, clean and rebuild?
It would be great to see a repo if you're still having issues.
Comment 3 Kevin Wong 2017-06-29 03:30:24 UTC
Sorry, we disabled AOT and are no longer tracking this issue.
Comment 4 Jon Douglas [MSFT] 2017-10-13 17:45:35 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Android. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.