Bug 45005 - Out of memory when building an Android project
Summary: Out of memory when building an Android project
Status: RESOLVED DUPLICATE of bug 43188
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: 7.0 (C8)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2016-10-04 11:37 UTC by Jiri Banas
Modified: 2016-10-04 15:27 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 43188

Description Jiri Banas 2016-10-04 11:37:32 UTC
I am getting an out of memory error when building an Android project. It survives about 4-5 builds before it throws the error. The remedy is to restart Xamarin Studio. After the next 4 - 5 successful builds the issue reoccurs. 

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.CSharp.targets: Project file could not be imported, it was being imported by <my_csproj_file_path>: Xamarin.Android.Common.targets: Project file could not be imported, it was being imported by /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.CSharp.targets: Out of memory

I did not have this problem with Xamarin Studio 6.0 and earlier.

Xamarin Studio Community - Version 6.1 (build 5441)
Mono 4.6.0 (mono-4.6.0-branch/746756c) (64-bit)
GTK+ 2.24.23 (Raleigh theme)
Package version: 406000245
Xamarin.Android - Version: 7.0.0.18 (Xamarin Studio Community)
SDK Tools Version: 25.2.2
SDK Platform Tools Version: 24.0.3
SDK Build Tools Version: 24.0.2
Java(TM) SE Runtime Environment (build 1.8.0_102-b14)

Build Information
Release ID: 601005441
Git revision: 68292d1ab289911c815ddc715dd7cc29a9752f9f
Build date: 2016-09-09 04:43:23-04
Xamarin addins: ed25d008672663eeb9db55f1ccecb3c24d2fd3b2
Build lane: monodevelop-lion-cycle8

Operating System
Mac OS X 10.12.1
Comment 1 dean.ellis 2016-10-04 15:27:19 UTC

*** This bug has been marked as a duplicate of bug 43188 ***