Bug 44980 - ActivityIndicator disappears when scrolling
Summary: ActivityIndicator disappears when scrolling
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.3.2
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-10-03 16:07 UTC by Hrafn Loftsson
Modified: 2017-07-18 10:04 UTC (History)
7 users (show)

See Also:
Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments

Description Hrafn Loftsson 2016-10-03 16:07:11 UTC
In iOS, an ActivityIndicator, which is a ViewCell in a ListView, disappears when scrolling. When the ViewCell moves off the visible screen area and back in during scrolling, the indicator is no longer visible.

This has been reported before: https://forums.xamarin.com/discussion/62974/activityindicator-disappears-while-scrolling-in-the-listview

I have made a test project which shows this behaviour: https://github.com/KolibriDev/TestLayoutXaml

Note that this is only a problem in iOS - works in Droid and UWP.
Comment 1 adrianknight89 2016-11-01 02:45:25 UTC
I can confirm this issue.

At the moment, I can't figure out what's causing this. A workaround seems to be setting IsRunning to false and then true. Add this to GetCell of ListViewRenderer:

if ((cell as ViewCell).View is ActivityIndicator)
{
    ((cell as ViewCell).View as ActivityIndicator).IsRunning = false;
    ((cell as ViewCell).View as ActivityIndicator).IsRunning = true;
}

Of course, this is not even a hack. If the activity indicator is a child of another element or elements, then you'd need to recursively search for it.
Comment 2 adrianknight89 2016-11-01 07:39:40 UTC
See https://github.com/xamarin/Xamarin.Forms/pull/495
Comment 3 Rui Marinho 2017-04-06 18:27:00 UTC
Should be fixed on 2.3.5-pre1
Comment 5 Paul DiPietro [MSFT] 2017-07-11 18:11:42 UTC
Please upload a reproduction project displaying the issue when running on the 2.3.5-pre6 build.
Comment 6 Saurabh Paunikar 2017-07-18 10:01:48 UTC
fixed on version 2.3.5-pre6.
Comment 7 Saurabh Paunikar 2017-07-18 10:04:00 UTC
Verified on xamarin.form version 2.3.5.256-pre6.
Hence marking this as verified.

ScreenCast link : https://www.screencast.com/t/lEP2M3gyPL

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.