Bug 44974 - [pdb] stepping over is not working
Summary: [pdb] stepping over is not working
Status: NEW
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2016-10-03 11:52 UTC by Marek Safar
Modified: 2016-10-03 12:06 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
dtest-app.zip (19.61 KB, application/zip)
2016-10-03 11:52 UTC, Marek Safar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 44974 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Marek Safar 2016-10-03 11:52:59 UTC
Created attachment 17846 [details]
dtest-app.zip

Using Mono.Debugger.Soft test suite I get following failure with attached .exe/.pdb

MonoTests.DebuggerTests.SingleStepping :   String lengths are both 11. Strings differ at index 10.
  Expected: "ss_nested_1"
  But was:  "ss_nested_2"
  ---------------------^

at MonoTests.DebuggerTests.assert_location (Mono.Debugger.Soft.Event e, System.String method) [0x0000e] in /Users/marek/git/my/mono/mcs/class/Mono.Debugger.Soft/Test/dtest.cs:531
at MonoTests.DebuggerTests.SingleStepping () [0x002be] in /Users/marek/git/my/mono/mcs/class/Mono.Debugger.Soft/Test/dtest.cs:748
at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00032] in <eb425e21f36c448aa8ee7cb1a6989b9d>:0