This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 44958 - No Available Devices are Listed After Changing Start Up Project via the Run button
Summary: No Available Devices are Listed After Changing Start Up Project via the Run b...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General (show other bugs)
Version: 4.2.0 (C8)
Hardware: PC Windows
: --- normal
Target Milestone: 4.2.1 (C8SR1)
Assignee: Bugzilla
URL:
: 44298 44900 45036 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-30 23:01 UTC by Jimmy [MSFT]
Modified: 2016-12-20 16:08 UTC (History)
10 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Jimmy [MSFT] 2016-09-30 23:01:30 UTC
### Overview
In Visual Studio 2015, changing the start up project does not list the emulators/devices available to deploy to. The issue occurs when using the drop down menu next to the Run button to select the start up project, but not when right-clicking the project in the solution explorer and selecting "Set as Start Up Project."

Some more observations:
- The project that is set as start up when the solution is first loaded will list the devices available
- Windows projects are unaffected by this issue, so if a Windows project is the start up project when loaded, no devices for Android / iOS will be listed. 


### Steps to Reproduce
1. Create a new or load an existing cross platform project in VS 2015
2. Use the drop down menu next to the Run arrow to select a different start up project


### Expected Results
The Run button will list the available devices/emulators to deploy the project.


### Actual Results
The button will say "Start" and not list any devices/emulators


### Workaround
Right click the project in the solution explorer and choose "Set as Start Up Project"


### Environment Info
Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01586

Installed Version: Enterprise

Architecture and Modeling Tools   00322-80000-00000-AA455
Microsoft Architecture and Modeling Tools
    
UML® and Unified Modeling Language™ are trademarks or registered trademarks of the Object Management Group, Inc. in the United States and other countries.

LightSwitch for Visual Studio 2015   00322-80000-00000-AA455
Microsoft LightSwitch for Visual Studio 2015

Visual Basic 2015   00322-80000-00000-AA455
Microsoft Visual Basic 2015

Visual C# 2015   00322-80000-00000-AA455
Microsoft Visual C# 2015

Visual C++ 2015   00322-80000-00000-AA455
Microsoft Visual C++ 2015

Windows Phone SDK 8.0 - ENU   00322-80000-00000-AA455
Windows Phone SDK 8.0 - ENU

Application Insights Tools for Visual Studio Package   7.8.00927.1
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 2015.1 (Beta8)   14.1.11107.0
ASP.NET and Web Tools 2015.1 (Beta8)

ASP.NET Web Frameworks and Tools 2012.2   4.1.41102.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.2.40314.0
For additional information, visit http://www.asp.net/

Clear MEF Component Cache   1.3.1
Clears the Visual Studio MEF component cache to fix issues with cache corruption.

Command Bus, Event Stream and Async Manager   Merq
Provides ICommandBus, IEventStream and IAsyncManager MEF services for loosely coupled Visual Studio extension components communication and integration.

Common Azure Tools   1.8
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

GitHub.VisualStudio   1.0
A Visual Studio Extension that brings the GitHub Flow into Visual Studio.

JavaScript Language Service   2.0
JavaScript Language Service

JavaScript Project System   2.0
JavaScript Project System

Microsoft Azure Mobile Services Tools   1.4
Microsoft Azure Mobile Services Tools

NuGet Package Manager   3.4.4
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

OptionsPackage Extension   1.0
OptionsPackage Visual Studio Extension Detailed Info

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools   14.0.60519.0
Microsoft SQL Server Data Tools

TypeScript   1.8.36.0
TypeScript tools for Visual Studio

Visual Studio Tools for Universal Windows Apps   14.0.25527.01
The Visual Studio Tools for Universal Windows apps allow you to build a single universal app experience that can reach every device running Windows 10: phone, tablet, PC, and more. It includes the Microsoft Windows 10 Software Development Kit.

Xamarin   4.2.0.698 (016ed17)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.0.1.2 (c1d1c79)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.0.0.1 (29910bb)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 2 Jose Gallardo 2016-10-11 20:46:01 UTC
This issue has been fixed in `master` and `cycle8` branches.

The fix was on private bug 44487 which has been already verified by QA.

*** This bug has been marked as a duplicate of bug 44487 ***
Comment 3 Jose Gallardo 2016-10-11 20:48:45 UTC
*** Bug 44900 has been marked as a duplicate of this bug. ***
Comment 4 Jose Gallardo 2016-10-19 22:40:08 UTC
*** Bug 44298 has been marked as a duplicate of this bug. ***
Comment 5 David 2016-10-29 04:20:51 UTC
I have this bug as well but I cannot view the bugs it is marked as a duplicate of and therefore can not see what the fix is.
Comment 6 Brendan Zagaeski (Xamarin Support) 2016-10-29 17:30:38 UTC
## Status clarification for any users watching this bug

The other Bug 44487 just says that a candidate fix for this issue is included in the current Beta versions of Cycle 8 Service Release 1.  That information is also recorded in the corresponding Release Blog post for the current Cycle 8 Service Release 1 Beta release:

> 44958 – No Available Devices are Listed After Changing Start Up
> Project via the Run button

https://releases.xamarin.com/beta-release-cycle-8-service-release-1/
Comment 7 Rod Barnes 2016-10-31 14:50:48 UTC
@David, the work around is to right-click the project and select the device from there rather than the menu bar.
Comment 8 Jose Gallardo 2016-12-20 16:08:15 UTC
*** Bug 45036 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.