This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 44926 - MTOUCH: error MT4109: Failed to compile the generated registrar code.
Summary: MTOUCH: error MT4109: Failed to compile the generated registrar code.
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools (show other bugs)
Version: XI 10.0 (iOS10)
Hardware: PC Mac OS
: --- normal
Target Milestone: (C9)
Assignee: rokvin
URL:
Depends on:
Blocks:
 
Reported: 2016-09-30 11:24 UTC by Volodymyr.Melnychenko
Modified: 2017-02-02 10:03 UTC (History)
4 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Env, registars, build log. (32.29 KB, application/zip)
2016-09-30 11:26 UTC, Volodymyr.Melnychenko
Details

Description Volodymyr.Melnychenko 2016-09-30 11:24:31 UTC
We have problems with generated registars for iOS Device. (Maybe problem with binding for GCDAsyncSocket generated by Sharpie)
Comment 1 Volodymyr.Melnychenko 2016-09-30 11:26:49 UTC
Created attachment 17824 [details]
Env, registars, build log.
Comment 2 Rolf Bjarne Kvinge 2016-09-30 13:31:27 UTC
It looks like there is a problem with a few methods/properties in some of your classes:

* AcceptDialogNotification: parameters
* CasinoAlertNotification: params
* DialogMessageResponse: params
* ErrorNotification: errorParams
* AuthenticationService: getUrlsForURLTypes:

Could you attach the C# code for these classes?
Comment 3 Volodymyr.Melnychenko 2016-10-03 05:46:16 UTC
This methods return or accept ObjectiveC generic collections.

AcceptDialogNotification
public NSArray<NSString> getParameters()

CasinoAlertNotification
public NSArray<NSString> getParams()

DialogMessageResponse
public NSArray<NSString> getParams()

ErrorNotification
public NSArray<NSString> getErrorParams()

AuthenticationService
public void getUrls(NSArray<NSString> urlTypes)

Behaviour is strange because we have another method in AuthenticationService with ObjC generics and application compile w/o errors.

AuthenticationService
public void setSessionParameters(NSDictionary<NSString, NSString> mappings)
Comment 4 Volodymyr.Melnychenko 2016-10-04 04:53:47 UTC
Any updates?
Comment 5 Rolf Bjarne Kvinge 2016-10-04 17:31:48 UTC
I'm fairly sure that should work, I'll have a look.

But can you try to bind using "string[]" instead of "NSArray<NSString>"? That might be a workaround.
Comment 6 Rolf Bjarne Kvinge 2016-10-28 15:51:23 UTC
PR: https://github.com/xamarin/xamarin-macios/pull/1063

Note You need to log in before you can comment on or make changes to this bug.