Bug 44896 - Failing to open external terminal in 6.1.1
Summary: Failing to open external terminal in 6.1.1
Status: CONFIRMED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger (show other bugs)
Version: 6.2.0 (C9)
Hardware: PC Linux
: Low normal
Target Milestone: Future Cycle (TBD)
Assignee: David Karlaš
URL:
Depends on:
Blocks:
 
Reported: 2016-09-29 18:00 UTC by harlauf
Modified: 2017-09-01 16:04 UTC (History)
1 user (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description harlauf 2016-09-29 18:00:05 UTC
System: Ubuntu GNOME amd64
mono version: Stable 4.6.1.3/abb06f1

When trying to run my project, one of two things happen:

With debugging on, it compiles, and then the play icon flickers to what I believe to be a stop icon, and then back again. No window opens

With debugging off, it says 'Cannot execute /path/to/program'. 

The files in the output are about between 1-2 hours old, according to the modification date. Building deletes all the files, and then seems to put them back again. Cleaning updates the modification date. 

mono seems to run the program normally

In extension to this, any button that involves an outside process does nothing (report bug, open containing folder)
Comment 1 harlauf 2016-10-01 07:01:13 UTC
When telling it not to run in an external console it works fine, but 'run with -> custom configuration' and turning on the external console option, it tells me that it "cannot execute /path/to/program"
Comment 2 harlauf 2016-11-28 18:15:04 UTC
Fixed with git update of f#, which I then had to compile from source
Comment 3 harlauf 2016-11-29 11:37:33 UTC
Only fixes on old version of monodevelop

Note You need to log in before you can comment on or make changes to this bug.