Bug 44830 - ListView not consistently focusing at the end of the list.
Summary: ListView not consistently focusing at the end of the list.
Status: RESOLVED DUPLICATE of bug 43313
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: unspecified
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-28 15:09 UTC by Sid Dubey
Modified: 2016-10-10 16:42 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample App (4.72 MB, application/x-zip-compressed)
2016-09-28 15:09 UTC, Sid Dubey
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 43313

Description Sid Dubey 2016-09-28 15:09:55 UTC
Created attachment 17786 [details]
Sample App

Initially when you enter the screen view of the list view it does not focus to the bottom of the list when the list contains more information that can be displayed on the screen view. When the list has a significant amount of content. It scrolls through the list until it gets to the bottom. Is there any way of just displaying the bottom without scrolling? That may alleviate the problem. If you leave the screen view with the listview, and then go back to that screen view, the list does focus at the bottom of the list.

It can be replicated easily. The Repro App is like a chat software where ListView gets populated with messages. When user exist the application and comes back, the ListView gets stuck somewhere in the middle and does not scroll till the bottom / last message. However if the user navigate to some other screen within the App and comes back .. it works just fine.
Comment 1 Ray Kelly 2016-09-29 16:32:22 UTC
This is probably a duplicate of this bug. 

https://bugzilla.xamarin.com/show_bug.cgi?id=43313

Its been broken for months and there is no workaround.  My chat app is stuck because of this.
Comment 2 Ray Kelly 2016-09-29 16:36:03 UTC
You may also want to follow this bug.  Same thing, been open forever and no fix.
https://bugzilla.xamarin.com/show_bug.cgi?id=28277
Comment 3 E.Z. Hart [MSFT] 2016-10-10 16:42:19 UTC

*** This bug has been marked as a duplicate of bug 43313 ***