Bug 44811 - NSInternalInconsistencyException : Could not load NIB in bundle
Summary: NSInternalInconsistencyException : Could not load NIB in bundle
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: XI 10.0 (iOS10)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-28 07:47 UTC by Ryoji.Ishikawa
Modified: 2017-01-04 20:38 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
sample project (20.33 KB, application/zip)
2016-09-29 03:26 UTC, Ryoji.Ishikawa
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Ryoji.Ishikawa 2016-09-28 07:47:15 UTC
The argument of ibtool is not correct.
As for the created file, a file name is changed (ie. ~iPad.nib -> ~ipad.nib)


# Supplemental info (logs, images, videos)
=========================================
		Tool /Applications/Xcode.app/Contents/Developer/usr/bin/ibtool execution started with arguments: --errors --warnings --notices --output-format xml1 --minimum-deployment-target 9.0 --target-device ipad --auto-activate-custom-fonts --sdk /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS10.0.sdk --link /Users/xxxxx/obj/iPhone/Debug/ibtool-link /Users/xxxxx/obj/iPhone/Debug/ibtool/Layout1~iPad.nib /Users/xxxxx/obj/iPhone/Debug/ibtool/Layout0~iPad.nib /Users/xxxxx/obj/iPhone/Debug/ibtool/Layout2~iPad.nib /Users/xxxxx/obj/iPhone/Debug/ibtool/Layout1~ipad.nib /Users/xxxxx/obj/iPhone/Debug/ibtool/Layout1.nib /Users/xxxxx/obj/iPhone/Debug/ibtool/Layout0~ipad.nib /Users/xxxxx/obj/iPhone/Debug/ibtool/Layout0.nib /Users/xxxxx/obj/iPhone/Debug/ibtool/Layout2~ipad.nib /Users/xxxxx/obj/iPhone/Debug/ibtool/Layout2.nib
		Tool /Applications/Xcode.app/Contents/Developer/usr/bin/ibtool execution finished (exit code = 0).
		  BundleResources Output:
		    obj/iPhone/Debug/ibtool-link/Layout1.nib/objects.nib
		    obj/iPhone/Debug/ibtool-link/Layout1.nib/runtime.nib
		    obj/iPhone/Debug/ibtool-link/Layout1~ipad.nib
		    obj/iPhone/Debug/ibtool-link/Layout0.nib/objects.nib
		    obj/iPhone/Debug/ibtool-link/Layout0.nib/runtime.nib
		    obj/iPhone/Debug/ibtool-link/Layout0~iPad.nib
		    obj/iPhone/Debug/ibtool-link/Layout2.nib/objects.nib
		    obj/iPhone/Debug/ibtool-link/Layout2.nib/runtime.nib
		    obj/iPhone/Debug/ibtool-link/Layout2~ipad.nib
		  OutputManifests Output:
		    obj/iPhone/Debug/ibtool-manifests/Layout1~iPad.nib
		    obj/iPhone/Debug/ibtool-manifests/Layout0~iPad.nib
		    obj/iPhone/Debug/ibtool-manifests/Layout2~iPad.nib
		    obj/iPhone/Debug/ibtool-manifests/Layout1.nib
		    obj/iPhone/Debug/ibtool-manifests/Layout0.nib
		    obj/iPhone/Debug/ibtool-manifests/Layout2.nib
		    obj/iPhone/Debug/ibtool-manifests/link
===========================================
why ibtool has duplicated argeuments?
i.e) "iPad" and "ipad"
/Users/xxxxx/obj/iPhone/Debug/ibtool-link /Users/xxxxx/obj/iPhone/Debug/ibtool/Layout1~iPad.nib
/Users/xxxxx/obj/iPhone/Debug/ibtool-link /Users/xxxxx/obj/iPhone/Debug/ibtool/Layout1~ipad.nib
Comment 1 Jeffrey Stedfast 2016-09-28 21:44:39 UTC
Can you create a sample project that illustrates this problem? I can't reproduce it locally.
Comment 2 Ryoji.Ishikawa 2016-09-29 03:26:33 UTC
Created attachment 17794 [details]
sample project
Comment 3 Ryoji.Ishikawa 2016-09-29 03:26:59 UTC
My environments.

=== Xamarin Studio Enterprise ===

Version 6.1.1 (build 15)
Installation UUID: 7a37a89e-52f0-49a6-9608-8e7393150974
Runtime:
	Mono 4.6.1 (mono-4.6.0-branch-c8sr0/abb06f1) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 406010003

=== NuGet ===

Version: 3.4.3.0

=== Xamarin.Profiler ===

Not Installed

=== Xamarin.Android ===

Version: 7.0.1.2 (Xamarin Enterprise)
Android SDK: /Developer/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)

SDK Tools Version: 22.6.3
SDK Platform Tools Version: 19.0.1
SDK Build Tools Version: 17.0.0

Java SDK: /usr
java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Not Installed

=== Apple Developer Tools ===

Xcode 8.0 (11246)
Build 8A218a

=== Xamarin.Mac ===

Not Installed

=== Xamarin.iOS ===

Version: 10.0.1.8 (Xamarin Enterprise)
Hash: 3983064
Branch: cycle8-sr0-xi
Build date: 2016-09-23 15:34:54-0400

=== Build Information ===

Release ID: 601010015
Git revision: fa52f02641726146e2589ed86ec4097fbe101888
Build date: 2016-09-22 08:03:02-04
Xamarin addins: 75d65712af93d54dc39ae4c42b21dfa574859fd6
Build lane: monodevelop-lion-cycle8-sr0

=== Operating System ===

Mac OS X 10.12.0
Darwin JPC20150005.local 16.0.0 Darwin Kernel Version 16.0.0
    Mon Aug 29 17:56:20 PDT 2016
    root:xnu-3789.1.32~3/RELEASE_X86_64 x86_64
Comment 4 Chris Hamons 2016-12-22 16:36:23 UTC
I can confirm, we appear to be stripping the capitalization off the xib when when process it (see attached project).

FlipsideView~ipad.nib