Bug 44777 - BarTextColor changes color for more than just the Navigation page
Summary: BarTextColor changes color for more than just the Navigation page
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.3.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-27 12:14 UTC by christine.blanda
Modified: 2016-11-16 20:19 UTC (History)
3 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample to recreate the issue - OBSOLETE (7.77 MB, application/x-zip-compressed)
2016-09-27 12:14 UTC, christine.blanda
Details
sample project recreating the issue (90.23 KB, application/x-zip-compressed)
2016-10-31 17:41 UTC, christine.blanda
Details
image showing current behavior and expected behavior (20.22 KB, image/png)
2016-10-31 17:43 UTC, christine.blanda
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description christine.blanda 2016-09-27 12:14:22 UTC
Created attachment 17761 [details]
Sample to recreate the issue - OBSOLETE

I have a MasterDetail page, Detail is a Naviagtion page, Master contains a Listview. I'm changing the color of the header bar background color and text using

((NavigationPage)Detail).BarBackgroundColor = Color.Navy;
((NavigationPage)Detail).BarTextColor = Color.White;

This changes the carrier bar text to white for both the Master and Detail sections, but only changes the carrier bar background on the Detail section, the Master is still white/transparent so the text is no longer visible. I would expect the bar variables to work the same, to only work on the Navigation page since that is the page they are being applied to.

note- I am NOT setting the StatusBarStyle to LightContent, the status bar on a content page shows as black text on a white background.
Comment 1 E.Z. Hart [MSFT] 2016-10-10 17:33:33 UTC
I'm attempting to reproduce the behavior you're describing with the attached sample, but so far I'm not able to. When I run the sample, the carrier text remains black. In fact, I can't find any changes to the BarBackgroundColor or BarTextColor properties in the sample.

Can you provide an updated sample which demonstrates the issue?
Comment 2 Samantha Houts [MSFT] 2016-10-29 00:44:28 UTC
Marking as duplicate of 37431

*** This bug has been marked as a duplicate of bug 37431 ***
Comment 3 christine.blanda 2016-10-31 17:41:57 UTC
Created attachment 18276 [details]
sample project recreating the issue
Comment 4 christine.blanda 2016-10-31 17:43:01 UTC
Created attachment 18278 [details]
image showing current behavior and expected behavior
Comment 5 Samantha Houts [MSFT] 2016-11-16 20:19:08 UTC
Should be fixed in 2.3.4-pre1. Please note that this is an opt-in fix. Please see https://github.com/xamarin/Xamarin.Forms/pull/517 for an example of disabling this behavior. Thank you!