Bug 44763 - Compilation crash MT0000
Summary: Compilation crash MT0000
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: XI 10.0 (iOS10)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: (C9)
Assignee: Rolf Bjarne Kvinge [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2016-09-27 04:39 UTC by Shay
Modified: 2016-10-18 08:10 UTC (History)
4 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Shay 2016-09-27 04:39:08 UTC
Log attached:

Rebuilding...

Cleaning: xfwatch (Release|iPhone)

Build started 9/27/2016 12:36:07 AM.
__________________________________________________
Project "/Users/shayo/Downloads/xfwatch/xfwatch/xfwatch.csproj" (Clean target(s)):
	
	Target CoreClean:
		Deleting file '/Users/shayo/Downloads/xfwatch/xfwatch/obj/iPhone/Release/Xamarin.iOS,Version=v1.0.AssemblyAttribute.cs'
		Deleting file '/Users/shayo/Downloads/xfwatch/xfwatch/obj/iPhone/Release/ibtool/_BundleResourceWithLogicalName.items'
		Deleting file '/Users/shayo/Downloads/xfwatch/xfwatch/obj/iPhone/Release/actool/_PartialAppManifest.items'
		Deleting file '/Users/shayo/Downloads/xfwatch/xfwatch/obj/iPhone/Release/actool/_BundleResourceWithLogicalName.items'
		Deleting file '/Users/shayo/Downloads/xfwatch/xfwatch/bin/iPhone/Release/xfwatch.exe.mdb'
		Deleting file '/Users/shayo/Downloads/xfwatch/xfwatch/bin/iPhone/Release/xfwatch.exe'
		Deleting file '/Users/shayo/Downloads/xfwatch/xfwatch/obj/iPhone/Release/xfwatch.exe'
		Deleting file '/Users/shayo/Downloads/xfwatch/xfwatch/obj/iPhone/Release/xfwatch.exe.mdb'
		Deleting file '/Users/shayo/Downloads/xfwatch/xfwatch/obj/iPhone/Release/xfwatch.csproj.FilesWrittenAbsolute.txt'
	
	Target _CleanITunesArtwork:
		Deleting file '/Users/shayo/Downloads/xfwatch/xfwatch/bin/iPhone/Release/iTunesMetadata.plist'
Done building project "/Users/shayo/Downloads/xfwatch/xfwatch/xfwatch.csproj".

Build succeeded.
	 0 Warning(s)
	 0 Error(s)

Time Elapsed 00:00:00.1647920

Building: xfwatch (Release|iPhone)

Build started 9/27/2016 12:36:07 AM.
__________________________________________________
Project "/Users/shayo/Downloads/xfwatch/xfwatch.xFUIiOSWatchAppExtension/xfwatch.xFUIiOSWatchAppExtension.csproj" (Build target(s)):
	
	Target _DetectAppManifest:
		FindItemWithLogicalName Task
		  Items:
		    Info.plist
		    Entitlements.plist
		  LogicalName: Info.plist
		  ProjectDir: /Users/shayo/Downloads/xfwatch/xfwatch.xFUIiOSWatchAppExtension
		  ResourcePrefix: Resources
	
	Target _DetectSdkLocations:
		DetectSdkLocations Task
		  TargetFrameworkIdentifier: Xamarin.WatchOS
		  TargetArchitectures: ARMv7k
		  SdkVersion: 3.0
		  XamarinSdkRoot: /Library/Frameworks/Xamarin.iOS.framework/Versions/Current
		  SdkRoot: /Applications/Xcode.app/Contents/Developer/Platforms/WatchOS.platform/Developer/SDKs/WatchOS3.0.sdk
		  SdkDevPath: /Applications/Xcode.app/Contents/Developer
		  SdkUsrPath: /Applications/Xcode.app/Contents/Developer/usr
		  SdkPlatform: WatchOS
		  SdkIsSimulator: False
	
	Target _DetectSigningIdentity:
		DetectSigningIdentity Task
		  AppBundleName: xfwatchxFUIiOSWatchAppExtension
		  AppManifest: Info.plist
		  Keychain: <null>
		  ProvisioningProfile: b1008946-3407-4c3d-88cf-e087c0795bbb
		  RequireCodesigning: True
		  SdkPlatform: WatchOS
		  SdkIsSimulator: False
		  SigningKey: iPhone Distribution
		Detected signing identity:
		  Code Signing Key: "iPhone Distribution: Shay Ohayon (8HG6W8XY26)" (46C907F7D7F828FA2A4A76C60BC9CC175DA7A73C)
		  Provisioning Profile: "AdHocProvision" (b1008946-3407-4c3d-88cf-e087c0795bbb)
		  Bundle Id: com.climbtag2.xfwatch.watchkitapp.watchkitextension
		  App Id: 8HG6W8XY26.com.climbtag2.xfwatch.watchkitapp.watchkitextension
	
	Target PrepareForBuild:
		Configuration: Release Platform: iPhone
	
	Target _BeforeCoreCompileInterfaceDefinitions:
	No input files were specified for target _BeforeCoreCompileInterfaceDefinitions, skipping.
	
	Target _CoreCompileInterfaceDefinitions:
	No input files were specified for target _CoreCompileInterfaceDefinitions, skipping.
	
	Target _BeforeCoreCompileImageAssets:
	Skipping target "_BeforeCoreCompileImageAssets" because its outputs are up-to-date.
	
	Target _CoreCompileImageAssets:
	Skipping target "_CoreCompileImageAssets" because its outputs are up-to-date.
	
	Target _CollectColladaAssets:
		CollectBundleResources Task
		  BundleResources: <null>
		  OptimizePropertyLists: False
		  OptimizePNGs: False
		  ProjectDir: /Users/shayo/Downloads/xfwatch/xfwatch.xFUIiOSWatchAppExtension
		  ResourcePrefix: Resources
	
	Target _CoreCompileColladaAssets:
	No input files were specified for target _CoreCompileColladaAssets, skipping.
	
	Target _BeforeCoreCompileSceneKitAssets:
	No input files were specified for target _BeforeCoreCompileSceneKitAssets, skipping.
	
	Target _CoreCompileSceneKitAssets:
	No input files were specified for target _CoreCompileSceneKitAssets, skipping.
	
	Target _BeforeCompileTextureAtlases:
	No input files were specified for target _BeforeCompileTextureAtlases, skipping.
	
	Target _CoreCompileTextureAtlases:
	No input files were specified for target _CoreCompileTextureAtlases, skipping.
	
	Target _CollectBundleResources:
		CollectBundleResources Task
		  BundleResources:
		  OptimizePropertyLists: True
		  OptimizePNGs: True
		  ProjectDir: /Users/shayo/Downloads/xfwatch/xfwatch.xFUIiOSWatchAppExtension
		  ResourcePrefix: Resources
	
	Target _CoreOptimizePngImages:
	No output files were specified for target _CoreOptimizePngImages, skipping.
	
	Target _CoreOptimizePropertyLists:
	No input files were specified for target _CoreOptimizePropertyLists, skipping.
	
	Target _CoreOptimizeLocalizationFiles:
	No input files were specified for target _CoreOptimizeLocalizationFiles, skipping.
	
	Target _UnpackLibraryResources:
		UnpackLibraryResources Task
		  Prefix: monotouch
		  IntermediateOutputPath: obj/iPhone/Release/
		  NoOverwrite:
		  ReferencedLibraries:
		    /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS/System.dll
		    /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS/System.Xml.dll
		    /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS/System.Core.dll
		    /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS/Xamarin.WatchOS.dll
		    /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS//mscorlib.dll
	
	Target GenerateSatelliteAssemblies:
	No input files were specified for target GenerateSatelliteAssemblies, skipping.
	
	Target _GenerateTargetFrameworkMonikerAttribute:
	Skipping target "_GenerateTargetFrameworkMonikerAttribute" because its outputs are up-to-date.
	
	Target CoreCompile:
	Skipping target "CoreCompile" because its outputs are up-to-date.
	
	Target _ComputeBundleResourceOutputPaths:
		ComputeBundleResourceOutputPaths Task
		  AppBundleDir: bin/iPhone/Release/xfwatchxFUIiOSWatchAppExtension.appex
		  BundleIdentifier: com.climbtag2.xfwatch.watchkitapp.watchkitextension
		  BundleResources: <null>
		  IntermediateOutputPath: obj/iPhone/Release/
		  OutputPath: bin/iPhone/Release/
	
	Target _CopyResourcesToBundle:
	No output files were specified for target _CopyResourcesToBundle, skipping.
	
	Target _CreateAssetPackManifest:
		CreateAssetPackManifest Task
		  AppBundleDir: bin/iPhone/Release/xfwatchxFUIiOSWatchAppExtension.appex
		  InitialInstallTags: <null>
		  OutputPath: bin/iPhone/Release/
		  PrefetchOrder: <null>
	
	Target _CompileEntitlements:
		CompileEntitlements Task
		  AppBundleDir: bin/iPhone/Release/xfwatchxFUIiOSWatchAppExtension.appex
		  AppIdentifier: 8HG6W8XY26.com.climbtag2.xfwatch.watchkitapp.watchkitextension
		  BundleIdentifier: com.climbtag2.xfwatch.watchkitapp.watchkitextension
		  CompiledEntitlements: obj/iPhone/Release/Entitlements.xcent
		  Entitlements: Entitlements.plist
		  IsAppExtension: True
		  ProvisioningProfile: b1008946-3407-4c3d-88cf-e087c0795bbb
		  SdkVersion: 3.0
	
	Target _DetectDebugNetworkConfiguration:
		DetectDebugNetworkConfiguration Task
		  DebugOverWiFi: False
		  DebuggerHosts: <null>
		  SdkIsSimulator: False
		  DebugIPAddresses: 
	
	Target _CompileAppManifest:
	Skipping target "_CompileAppManifest" because its outputs are up-to-date.
	
	Target _GetNativeExecutableName:
		GetNativeExecutableName Task
		  AppManifest: bin/iPhone/Release/xfwatchxFUIiOSWatchAppExtension.appex/Info.plist
	
	Target _CompileToNative:
		MTouch Task
		  AppBundleDir: bin/iPhone/Release/xfwatchxFUIiOSWatchAppExtension.appex
		  AppExtensionReferences:
		  AppManifest: bin/iPhone/Release/xfwatchxFUIiOSWatchAppExtension.appex/Info.plist
		  Architectures: ARMv7k
		  ArchiveSymbols: <null>
		  BitcodeEnabled: True
		  CompiledEntitlements: obj/iPhone/Release/Entitlements.xcent
		  Debug: False
		  EnableGenericValueTypeSharing: True
		  Entitlements: Entitlements.plist
		  ExecutableName: xfwatchxFUIiOSWatchAppExtension
		  ExtraArgs: <null>
		  FastDev: False
		  HttpClientHandler: HttpClientHandler
		  I18n: <null>
		  IntermediateOutputPath: obj/iPhone/Release/mtouch-cache
		  IsAppExtension: True
		  LinkerDumpDependencies: False
		  LinkMode: SdkOnly
		  MainAssembly: /Users/shayo/Downloads/xfwatch/xfwatch.xFUIiOSWatchAppExtension/bin/iPhone/Release//xfwatchxFUIiOSWatchAppExtension.dll
		  NativeReferences: <null>
		  OutputPath: bin/iPhone/Release/
		  Profiling: False
		  ProjectDir: /Users/shayo/Downloads/xfwatch/xfwatch.xFUIiOSWatchAppExtension
		  References:
		    /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS/System.dll
		    /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS/System.Xml.dll
		    /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS/System.Core.dll
		    /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS/Xamarin.WatchOS.dll
		    /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS//mscorlib.dll
		  SdkIsSimulator: False
		  SdkRoot: /Applications/Xcode.app/Contents/Developer
		  SdkVersion: 3.0
		  SymbolsList: obj/iPhone/Release/mtouch-symbols.list
		  TargetFrameworkIdentifier: Xamarin.WatchOS
		  TLSProvider: Default
		  UseFloat32: True
		  UseLlvm: True
		  UseThumb: False
		  Verbosity: 2
		Tool /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/bin/mtouch execution started with arguments: --cache /Users/shayo/Downloads/xfwatch/xfwatch.xFUIiOSWatchAppExtension/obj/iPhone/Release/mtouch-cache --dev /Users/shayo/Downloads/xfwatch/xfwatch.xFUIiOSWatchAppExtension/bin/iPhone/Release/xfwatchxFUIiOSWatchAppExtension.appex --executable xfwatchxFUIiOSWatchAppExtension --extension --linksdkonly --sdkroot /Applications/Xcode.app/Contents/Developer --sdk 3.0 --targetver 2.2 --aot-options=-O=float32 --bitcode=full --http-message-handler=HttpClientHandler --tls-provider=default --abi=armv7k+llvm --symbollist /Users/shayo/Downloads/xfwatch/xfwatch.xFUIiOSWatchAppExtension/obj/iPhone/Release/mtouch-symbols.list --dsym=no -r /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS/System.dll -r /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS/System.Xml.dll -r /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS/System.Core.dll -r /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS/Xamarin.WatchOS.dll -r /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/lib/mono/Xamarin.WatchOS/mscorlib.dll --target-framework Xamarin.WatchOS,v1.0 /Users/shayo/Downloads/xfwatch/xfwatch.xFUIiOSWatchAppExtension/bin/iPhone/Release//xfwatchxFUIiOSWatchAppExtension.dll -v -v 
		Using Xcode 8.0 found in /Applications/Xcode.app/Contents/Developer
		Xamarin.iOS 10.0.0.6 (xcode8: 6c3fee4) using framework: /Applications/Xcode.app/Contents/Developer/Platforms/WatchOS.platform/Developer/SDKs/WatchOS3.0.sdk
MTOUCH: error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
		System.NullReferenceException: Object reference not set to an instance of an object
		  at Xamarin.Bundler.Target.ProcessAssemblies () [0x000fa] in <86a99508958c45bc8a05d21e3b49a458>:0 
		  at Xamarin.Bundler.Application.BuildApp () [0x0002f] in <86a99508958c45bc8a05d21e3b49a458>:0 
		  at Xamarin.Bundler.Application.Build () [0x00052] in <86a99508958c45bc8a05d21e3b49a458>:0 
		  at Xamarin.Bundler.Driver.Main2 (System.String[] args) [0x01c6c] in <86a99508958c45bc8a05d21e3b49a458>:0 
		  at Xamarin.Bundler.Driver.Main (System.String[] args) [0x0000c] in <86a99508958c45bc8a05d21e3b49a458>:0 
	Task "MTouch" execution -- FAILED
	Done building target "_CompileToNative" in project "/Users/shayo/Downloads/xfwatch/xfwatch.xFUIiOSWatchAppExtension/xfwatch.xFUIiOSWatchAppExtension.csproj".-- FAILED
	
Done building project "/Users/shayo/Downloads/xfwatch/xfwatch.xFUIiOSWatchAppExtension/xfwatch.xFUIiOSWatchAppExtension.csproj".-- FAILED

Build FAILED.
Errors:

/Users/shayo/Downloads/xfwatch/xfwatch.xFUIiOSWatchAppExtension/xfwatch.xFUIiOSWatchAppExtension.csproj (Build) ->
/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets (_CompileToNative target) ->

	MTOUCH: error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com

	 0 Warning(s)
	 1 Error(s)

Time Elapsed 00:00:00.9069330

---------------------- Done ----------------------

Build: 1 error, 0 warnings
Comment 1 Vincent Dondain [MSFT] 2016-09-27 17:17:12 UTC
I suspect this is a duplicate of https://bugzilla.xamarin.com/show_bug.cgi?id=44610.

Please try to change the HttpClient implementation of the Watch Extension and main app to NSUrlSession. In the future it won't be possible to select HttpClientHandler for watchOS projects.

Also feel free to re-open this bug if it doesn't fix your issue.

*** This bug has been marked as a duplicate of bug 44610 ***
Comment 2 Rolf Bjarne Kvinge [MSFT] 2016-10-06 10:17:15 UTC
This is an issue with cached builds:

    MTOUCH: error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
	System.NullReferenceException: Object reference not set to an instance of an object
	  at Xamarin.Bundler.Target.ProcessAssemblies () [0x000fa] in <86a99508958c45bc8a05d21e3b49a458>:0 
	  at Xamarin.Bundler.Application.BuildApp () [0x0002f] in <86a99508958c45bc8a05d21e3b49a458>:0 
	  at Xamarin.Bundler.Application.Build () [0x00052] in <86a99508958c45bc8a05d21e3b49a458>:0 
	  at Xamarin.Bundler.Driver.Main2 (System.String[] args) [0x01c6c] in <86a99508958c45bc8a05d21e3b49a458>:0 
	  at Xamarin.Bundler.Driver.Main (System.String[] args) [0x0000c] in <86a99508958c45bc8a05d21e3b49a458>:0
Comment 4 Danish Akhtar 2016-10-18 08:10:27 UTC
I have checked this with latest C9 XS 6.2(build 844) and observed that now this issue is not exits, watch app is build successfully in both debug and release mode. Also there is no option exists for CFNetworkHandler or http client handler for Watch application, it takes default client handler for watchOS projects is NSUrlSessionHandler.

Here is the screencast for the same: http://www.screencast.com/t/l73cnm7MoG

Hence closing this issue.

Env info: https://gist.github.com/NaqeebAnsari/73cb895c78ec08acf0c31376953052f7

Note You need to log in before you can comment on or make changes to this bug.