Bug 44724 - Failed to read file attributes for "/Users/admin/Assets.xcassets"
Summary: Failed to read file attributes for "/Users/admin/Assets.xcassets"
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: 4.2.0 (C8)
Hardware: PC Windows
: High critical
Target Milestone: 4.2.1 (C8SR1)
Assignee: Emanuel
URL:
Depends on:
Blocks:
 
Reported: 2016-09-26 07:26 UTC by Anton
Modified: 2016-11-02 04:03 UTC (History)
16 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Anton 2016-09-26 07:26:40 UTC
Severity	Code	Description	Project	File	Line	Suppression State
Error		Failed to read file attributes for "/Users/admin/Assets.xcassets"	Sledi.iOS	C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets	1028
Comment 1 Vincent Dondain [MSFT] 2016-09-26 15:36:38 UTC
Hi, I'm having a hard time understand how exactly you got this error. Seems that your asset folder is located in a place where it did not automatically get read rights. It does not seem to be the project default's asset folder.

To help you with this bug, we'd need at least a full verbose build log as well, if possible, as a test case.
Comment 2 Simon Belanger 2016-09-27 13:21:54 UTC
I think I experienced the same bug, what fixed it for me was to create (in my case it was missing) the /users/[username]/Library/Caches/Xamarin/Resources folder on my build machine (mac agent) and copy the *.xcassets from my PC containing the project to this new folder.

The bug was originating from the ACTool task failing when it could not find the aforementioned folder.
Comment 4 Adam Hartley [MSFT] 2016-09-30 11:38:43 UTC
Verbose build log after deleting the builds folder:

https://gist.githubusercontent.com/BytesGuy/4ad7d7df69588311966e9e2543d3a9c2/raw/3f7aac89151528aff0b5ffdb7c50ec9b913bcd8b/gistfile1.txt
Comment 5 Daniel Cazzulino 2016-10-04 13:51:02 UTC
Investigating. 

Thanks for providing the build log!
Comment 8 Pierce Boggan [MSFT] 2016-10-07 19:26:56 UTC
I'm also able to reproduce this in the Cycle 8, SR0 bits in Stable channel.

Microsoft Visual Studio Community 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01586

Installed Version: Community

Visual Basic 2015   00322-20000-00000-AA140
Microsoft Visual Basic 2015

Visual C# 2015   00322-20000-00000-AA140
Microsoft Visual C# 2015

Visual C++ 2015   00322-20000-00000-AA140
Microsoft Visual C++ 2015

Visual F# 2015   00322-20000-00000-AA140
Microsoft Visual F# 2015

Windows Phone SDK 8.0 - ENU   00322-20000-00000-AA140
Windows Phone SDK 8.0 - ENU

Application Insights Tools for Visual Studio Package   7.8.00927.1
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 2015.1 (Beta8)   14.1.11107.0
ASP.NET and Web Tools 2015.1 (Beta8)

ASP.NET Web Frameworks and Tools 2012.2   4.1.41102.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.2.40314.0
For additional information, visit http://www.asp.net/

Command Bus, Event Stream and Async Manager   Merq
Provides ICommandBus, IEventStream and IAsyncManager MEF services for loosely coupled Visual Studio extension components communication and integration.

Common Azure Tools   1.8
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

GitHub.VisualStudio   1.0
A Visual Studio Extension that brings the GitHub Flow into Visual Studio.

JavaScript Language Service   2.0
JavaScript Language Service

JavaScript Project System   2.0
JavaScript Project System

Microsoft Azure Mobile Services Tools   1.4
Microsoft Azure Mobile Services Tools

NuGet Package Manager   3.4.4
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools   14.0.60519.0
Microsoft SQL Server Data Tools

TypeScript   1.8.36.0
TypeScript tools for Visual Studio

Visual Studio Tools for Universal Windows Apps   14.0.25527.01
The Visual Studio Tools for Universal Windows apps allow you to build a single universal app experience that can reach every device running Windows 10: phone, tablet, PC, and more. It includes the Microsoft Windows 10 Software Development Kit.

Xamarin   4.2.0.703 (3b7df6f)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.0.1.3 (96c7ba6)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.0.1.10 (ad1cd42)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 9 xamarin-release-manager 2016-10-27 14:49:53 UTC
Fixed in version 4.2.1.38 (cycle8)

Author: Emanuel
Commit: d8362f6ff617a377716218fc82960223af886a67 (xamarin/xamarin-macios)
Included in Commit: cc0442630a2e74d7c5234848975e345f2c9fd01b (xamarin/XamarinVS)
Comment 11 Ben Beckley 2016-10-31 17:56:52 UTC
I was able to reproduce this using 4.2.0.680 (cycle8/c4382f5) by replicating the directory structure of the solution in the build folder on my Mac agent.

Reproduction steps:
1) Create an iOS app with an asset catalog
2) Build the app while connected to a build agent
3) Navigate to the build folder on the build agent. For me it was:
>/Users/Ben/Library/Caches/Xamarin/mtbs/builds/PhotoProgress/1df5529ebffd716aaa1320f2b58351a2/
4) Get the path to the csproj on the Windows machine. For me it was:
>C:\GIT\ios-samples\ios9\PhotoProgress\PhotoProgress
5) Replicate that path in the build folder on the Mac agent. It will look like this:
>/Users/Ben/Library/Caches/Xamarin/mtbs/builds/PhotoProgress/1df5529ebffd716aaa1320f2b58351a2/c//GIT/ios-samples/ios9/PhotoProgress/PhotoProgress
6)Rebuild the project and observe the error:
>Failed to read file attributes for "/Users/Ben/Library/Resources/Images.xcassets"

Env info: https://gist.github.com/BenBeckley/41df47bddd63304c9293a695fbfcff5f


I was able to verify the fix using 4.2.1.38 (cycle8/b5dcaca) as I was not able to reproduce the error.

Win env: https://gist.github.com/BenBeckley/d10f90dca25134c8764d23033062a9ca
Mac env: https://gist.github.com/BenBeckley/1b43ac56384c20375a139dd5a96b5eac
Comment 12 Ben Beckley 2016-10-31 17:59:43 UTC
Slight typo in comment 11, the tested build was actually 4.2.1.45

4.2.1.38 is the build where the fix was introduced
Comment 13 Brendan Zagaeski (Xamarin Support) 2016-11-02 04:03:24 UTC
## Bookkeeping

Adjusting target milestone to Cycle 8 SR 1 for precise bookkeeping based on the verification from Comment 11.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.