Bug 44615 - Mono 4.6 - Secure Channel Failure with Duplicati
Summary: Mono 4.6 - Secure Channel Failure with Duplicati
Status: RESOLVED DUPLICATE of bug 26658
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 4.6.0 (C8)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-22 09:41 UTC by Lannes-Lacrouts Guillaume
Modified: 2017-08-28 15:05 UTC (History)
3 users (show)

Tags: urgent
Is this bug a regression?: ---
Last known good build:


Attachments
Password of owncloud account (10 bytes, text/plain)
2016-09-22 09:41 UTC, Lannes-Lacrouts Guillaume
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 26658

Description Lannes-Lacrouts Guillaume 2016-09-22 09:41:42 UTC
Created attachment 17668 [details]
Password of owncloud account

Hello,

I have a problem with Duplicati ( it use MONO 4.6)  . I have an error " Secure Channel Failure ( the authentication or decryption has failed)" 

It's occur when i try to connect on a Webdav (Owncloud) Server.

Server : mycore.core-cloud.net

Port : 443 

Use SSL is ticked 

remote path : remote.php/webdav/

Username : testgll

When i see the duplicati log , it's clearly a Mono Exception
Comment 1 Lannes-Lacrouts Guillaume 2016-09-22 09:43:56 UTC
System.Net.WebException: Error: SecureChannelFailure (The authentication or decryption has failed.) ---> System.IO.IOException: The authentication or decryption has failed. ---> System.IO.IOException: The authentication or decryption has failed. ---> Mono.Security.Protocol.Tls.TlsException: The authentication or decryption has failed.
at Mono.Security.Protocol.Tls.RecordProtocol.EndReceiveRecord (System.IAsyncResult asyncResult) [0x00040] in <78782669c99b48d9aeebe3c363ec7720>:0
at Mono.Security.Protocol.Tls.SslClientStream.SafeEndReceiveRecord (System.IAsyncResult ar, System.Boolean ignoreEmpty) [0x00000] in <78782669c99b48d9aeebe3c363ec7720>:0
at Mono.Security.Protocol.Tls.SslClientStream.NegotiateAsyncWorker (System.IAsyncResult result) [0x00071] in <78782669c99b48d9aeebe3c363ec7720>:0
--- End of inner exception stack trace ---
at Mono.Security.Protocol.Tls.SslClientStream.EndNegotiateHandshake (System.IAsyncResult result) [0x0003b] in <78782669c99b48d9aeebe3c363ec7720>:0
at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (System.IAsyncResult asyncResult) [0x0000c] in <78782669c99b48d9aeebe3c363ec7720>:0
--- End of inner exception stack trace ---
at Mono.Security.Protocol.Tls.SslStreamBase.EndRead (System.IAsyncResult asyncResult) [0x00057] in <78782669c99b48d9aeebe3c363ec7720>:0
at Mono.Net.Security.Private.LegacySslStream.EndAuthenticateAsClient (System.IAsyncResult asyncResult) [0x00011] in :0
at Mono.Net.Security.Private.LegacySslStream.AuthenticateAsClient (System.String targetHost, System.Security.Cryptography.X509Certificates.X509CertificateCollection clientCertificates, System.Security.Authentication.SslProtocols enabledSslProtocols, System.Boolean checkCertificateRevocation) [0x0000e] in :0
at Mono.Net.Security.MonoTlsStream.CreateStream (System.Byte[] buffer) [0x00044] in :0
--- End of inner exception stack trace ---
at Duplicati.Library.Utility.AsyncHttpRequest+AsyncWrapper.GetResponseOrStream () [0x00056] in <8331c27918ed41618e86730af9347320>:0
at Duplicati.Library.Utility.AsyncHttpRequest.GetRequestStream () [0x00042] in <8331c27918ed41618e86730af9347320>:0
at Duplicati.Library.Backend.WEBDAV.List () [0x0004c] in :0
Comment 2 Lannes-Lacrouts Guillaume 2016-10-10 08:49:54 UTC
Hello, anyone ?
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2016-10-21 17:21:03 UTC
According to https://www.ssllabs.com/ssltest/, mycore.core-cloud.net only supports the following Cipher Suites:

LS_DHE_RSA_WITH_AES_256_CBC_SHA
TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA
TLS_DHE_RSA_WITH_AES_256_GCM_SHA384
TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384
TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA
TLS_DHE_RSA_WITH_SEED_CBC_SHA
TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256
TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA

The Mono TLS implementation does not currently support Diffie–Hellman key agreement (DHE, ECDHE).

*** This bug has been marked as a duplicate of bug 26658 ***
Comment 4 Lannes-Lacrouts Guillaume 2016-10-22 09:48:09 UTC
Hello , Thanks for your answer.

I send a message to the duplicati Team ( kenneth) on the github issue that i opened.