Bug 44607 - 500 Error - SignalR 2 with Mono 4.6.0 (Linux - Raspbian)
Summary: 500 Error - SignalR 2 with Mono 4.6.0 (Linux - Raspbian)
Status: NEW
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: 4.6.0 (C8)
Hardware: Other Linux
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2016-09-22 04:09 UTC by marcus
Modified: 2016-09-22 04:09 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Error screen capture (132.54 KB, image/png)
2016-09-22 04:09 UTC, marcus
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 44607 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description marcus 2016-09-22 04:09:29 UTC
Created attachment 17663 [details]
Error screen capture

Mono Version Information: 4.6.0 (Stable 4.6.0.245/746756c Wed Sep 14 10:14:19 UTC 2016); ASP.NET Version: 4.0.30319.42000
Hardware: Raspberry Pi 2
OS: Raspbian 


I follow the SignalR 2.x tutorial :
http://www.asp.net/signalr/overview/getting-started/tutorial-getting-started-with-signalr


when I tried to run the SignalR 2.x Tutorial project with Mono 4.6.0 on Raspberry Pi 2, I got 500 error:

System.InvalidOperationException
Operation is not valid due to the current state of the object.
(Attached a screen capture)


project github link:   https://github.com/luckyus/mono420_signalR2.git

(Please ignore the readme description - it is bug 33809 and fixed https://bugzilla.xamarin.com/show_bug.cgi?id=33809)


Thanks