This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 44578 - Cannot debug any solution from VS on my iPad anymore
Summary: Cannot debug any solution from VS on my iPad anymore
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: 4.2.0 (C8)
Hardware: PC Windows
: High blocker
Target Milestone: 4.2.1 (C8SR1)
Assignee: mag@xamarin.com
URL:
Depends on:
Blocks: 44366
  Show dependency tree
 
Reported: 2016-09-21 15:19 UTC by Michael Rumpler
Modified: 2016-10-27 13:30 UTC (History)
10 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Michael Rumpler 2016-09-21 15:19:00 UTC
# Steps to reproduce

I followed http://motzcod.es/post/150380059392/preparing-machines-for-xamarin-cycle to install cycle 8 and all dependencies. I don't know anymore, whether I rebooted my machines after the install before I ran into bug 44366. However, I tried if a reboot (both Windows and iOS build host) fixes that bug, but now I cannot debug any project on my iPad4 with iOS 9.3.3 anymore.
I open any Xamarin.Forms solution in Visual Studio 2015 prof and try to run the iOS project on my iPad with F5 (Start Debugging) or Ctrl-F5 (Start Without Debugging). Then the app is built, deployed and started. I do see the launch images. If I set a breakpoint somewhere near the start (e.g. AppDelegate.FinishedLaunching), then the breakpoint is hit, but before the 17 seconds are over the iPad jumps back to the springboard and VS stops debugging. When I tap the home button twice, I see that the app is still running and I can switch to it and use it without problems.

In the output window I only see:

Launch failed. The app 'Repro44366.iOS' could not be launched on 'Michaels iPad'. Please check the logs for more details.
The app has been terminated.

The log file contains:

Xamarin.Messaging.Client.MessagingClient Error: 0 : [2016-09-20 15:47:45.6810] An error occured on the receiver while executing a post for topic xvs/idb/4.2.0.680/launch-app and client vs6972Micha
Xamarin.Messaging.Exceptions.MessagingRemoteException: An error occured on client IDB420680 while executing a reply for topic xvs/idb/4.2.0.680/launch-app ---> System.FormatException: Input string was not in a correct format.

and

Xamarin.Messaging.Exceptions.MessagingRemoteException: An error occured on client IDB420680 while executing a reply for topic xvs/idb/4.2.0.680/launch-app ---> Xamarin.Messaging.Exceptions.MonotouchException: 2016-09-20 15:50:02.600 mlaunch[1198:11924] Connection peer refused channel request for "com.apple.instruments.server.services.processcontrol"; channel canceled <DTXChannel: 0x7fd0241a9320>
error MT1007: Failed to launch the application '/Users/Michael/Library/Caches/Xamarin/mtbs/builds/GestureSample.iOS/3005e292840f243bc596f074de6e64ce/bin/iPhone/Debug/GestureSampleiOS.app' on the device 'Michaels iPad': Object reference not set to an instance of an object. You can still launch the application manually by tapping on it.

I already attached the log to bug 44366. It is available at https://bugzilla.xamarin.com/attachment.cgi?id=17613

I tried several solutions, all with the same result. In my main app I enabled device-specific builds, but in the others not.

This may be related to https://bugzilla.xamarin.com/show_bug.cgi?id=44366, but I'm not sure. As Brendan explained in https://bugzilla.xamarin.com/show_bug.cgi?id=44366#c7 it may also be related to https://bugzilla.xamarin.com/show_bug.cgi?id=44301 but as that bug is not public, I cannot verify it.

# Test environment (full version information)

Windows:
Windows 10
Microsoft Visual Studio Professional 2015, Version 14.0.25431.01 Update 3
Xamarin   4.2.0.680 (c4382f5)
Xamarin.iOS   10.0.0.6 (6c3fee4)

Mac:
OS X El Capitan, 10.11.5
Xcode Version 8.0 (8A218a)
Xamarin Studio Professional Version 6.1 (build 5441)
Xamarin.iOS Version: 10.0.0.6 (Visual Studio Professional)
Hash: 6c3fee4
Branch: xcode8
Build date: 2016-09-09 13:01:32-0400
Comment 1 Michael Rumpler 2016-09-21 15:20:04 UTC
I forgot to mention: When I run the app on the iPhone 5 iOS 10 simulator, then I can debug it as expected.
Comment 2 Brendan Zagaeski 2016-09-21 23:26:23 UTC
Thanks for the report.  I'm working on gathering data across this bug as well as the similar-looking bugs Bug 44567 and non-public Bug 44301.


To help provide as many shared data points as possible across the three bug reports, if you might be able to add the following details for your particular environment, that would be perfect:



1. Can you replicate the problem using a new "Single View (iPhone)" project or a new "Blank Xaml App (Xamarin.Forms Portable)" project?



2. As far as you've seen, does the problem happen on every attempt to debug?  Or does debugging occasionally work successfully?



3. Are you using any non-English/USA region and language settings on Windows, Mac, or the device?



4. To provide one more bit of version information to be thorough, you can paste back your Mono version information, for example by copy/pasting the top line from the output of the following command in a Terminal.app prompt:

mono --version



5. If you get a chance, please also collect and attach back the system log from the iOS device [1] for the time surrounding the failed debugging attempt.

For example, you can use the new device log feature in VS [1], or find the logs under the disclosure arrow at the bottom of the  "Window -> Devices -> ${DeviceName}" window in Xcode [2].

[1] https://developer.xamarin.com/releases/vs/xamarin.vs_4/xamarin.vs_4.2/#devicelog
[2] See "iOS Device Logs" on https://kb.xamarin.com/customer/en/portal/articles/1675684-where-can-i-find-my-version-information-and-logs-#ios-device-logs



Thanks in advance!
Comment 3 Brendan Zagaeski 2016-09-22 03:16:05 UTC
## Update on question 5

(a) There is a chance the underlying problem for this bug might be tied to Bug 44605 that I have just characterized and filed.  Hopefully your iOS device log will give us some further clues about whether that might be the case.

(b) Having now recently experimented with the 2 log viewer options, I would recommend using the Xcode device log viewer for now rather than the new iOS log viewer XamarinVS preview feature.  It appears that the log viewer in VS doesn't yet live-update its entries, so it is trickier to capture the desired set of lines.
Comment 4 Michael Rumpler 2016-09-22 08:31:41 UTC
1. Yes, one of the three solutions I tried has just been created based on "Blank Xaml App (Xamarin.Forms Portable)". I just added two lines with Debug.WriteLine. The project was created with XF 2.2.0.45 and I couldn't debug it. Updating it to XF 2.3.3.152-pre2 didn't help. That solution does not use device-specific builds.

2. It fails every time on the iPad.
When I tried it the very first time in the iPhone 5 iOS 10 simulator, it also jumped back to the springboard, but VS did not stop debugging and the app was still open. But on every following try, the app stayed open and visible and it worked as expected.

3. Yes, The language is set to English, but the region is Austria on both the iPad and OS X build host. For some reason the PCs region was set to UK. I changed that to Austria too now.

4. Mono JIT compiler version 4.6.0 (mono-4.6.0-branch/746756c Thu Sep  8 05:39:12 EDT 2016)

5. I checked the VS device log before, but it did not print anything at all. Thats probably because of the bug you mentioned in Comment 3.

In Xcode I see:

Sep 22 10:22:48 Michaels-iPad gputoolsd[1600] <Notice>: schedule invalidation <DYTransport 0x14d488b0, error: lost transport connection (31)>
Sep 22 10:22:48 Michaels-iPad gputoolsd[1600] <Notice>: terminating daemon 0x14e3ae70
Sep 22 10:22:48 Michaels-iPad timed[1077] <Notice>: (Note ) CoreTime: Received time 09/22/2016 08:22:47±0.03 from "NTP"
Sep 22 10:22:48 Michaels-iPad timed[1077] <Notice>: (Note ) CoreTime: Want active time in 23.43min. Need active time in 8315.10min. Remaining retry interval: 14.966667min.
Sep 22 10:22:48 Michaels-iPad UserEventAgent[1059] <Error>: validateAndAddDefaults(com.apple.timed): End Time (inf) > now (496225369.0) + BACKGROUND_TASK_AGENT_JOB_WINDOW_MAX_TIME_FROM_NOW_SEC (3024000.0) + BACKGROUND_TASK_AGENT_JOB_TIME_ERROR_MARGIN (300.0)
Sep 22 10:22:49 Michaels-iPad timed[1077] <Notice>: (Error) CoreTime: Error requesting proactive time check job
Sep 22 10:23:09 Michaels-iPad installd[1079] <Notice>: 0x40115000 -[MIClientConnection _doBackgroundInstallationForPath:withOptions:completion:]: Install of "/var/mobile/Media/PublicStaging/Repro44366.iOS.app_sparse.ipa" type Developer (LSInstallType = (null)) requested by streaming_zip_conduit (pid 1359)
Sep 22 10:23:09 Michaels-iPad installd[1079] <Notice>: 0x40115000 -[MIInstaller performInstallationWithError:]: Installing <MIInstallableBundlePatch ID=com.yourcompany.Repro44366; Version=1.0, ShortVersion=1.0>
Sep 22 10:23:09 Michaels-iPad installd[1079] <Notice>: 0x40115000 -[MIInstallableBundlePatch applyPatchWithError:]: Attempting patch update of com.yourcompany.Repro44366 from 1.0 (1.0) to 1.0 (1.0)
Sep 22 10:23:09 Michaels-iPad installd[1079] <Notice>: 0x40115000 -[MIInstallableBundle performPreflightWithError:]: Setting skip watch app install flag
Sep 22 10:23:09 Michaels-iPad profiled[1173] <Notice>: (Note ) MC: Provisioning profiles changed
Sep 22 10:23:09 Michaels-iPad profiled[1173] <Notice>: (Note ) MC: Updating MIS trust...
Sep 22 10:23:09 Michaels-iPad securityd[1124] <Error>:  secTaskDiagnoseEntitlements MISSING keychain entitlements: no stored taskRef found
Sep 22 10:23:09 Michaels-iPad securityd[1124] <Error>:  secTaskDiagnoseEntitlements MISSING keychain entitlements: no stored taskRef found
Sep 22 10:23:09 Michaels-iPad installd[1079] <Error>:  SecTrustEvaluate  [leaf IssuerCommonName SubjectCommonName]
Sep 22 10:23:09 Michaels-iPad securityd[1124] <Error>:  secTaskDiagnoseEntitlements MISSING keychain entitlements: no stored taskRef found
Sep 22 10:23:09 Michaels-iPad securityd[1124] <Error>:  secTaskDiagnoseEntitlements MISSING keychain entitlements: no stored taskRef found
Sep 22 10:23:09 Michaels-iPad installd[1079] <Error>:  SecTrustEvaluate  [leaf IssuerCommonName SubjectCommonName]
Sep 22 10:23:10 Michaels-iPad installd[1079] <Notice>: 0x40115000 -[MIInstallableBundle _refreshUUIDForContainer:withError:]: Data container for com.yourcompany.Repro44366 is now at /private/var/mobile/Containers/Data/Application/E6C17FDF-72AC-4716-9FA1-4963CC2DB769
Sep 22 10:23:10 Michaels-iPad installd[1079] <Notice>: 0x40115000 -[MIContainer makeContainerLiveReplacingContainer:reason:withError:]: Made container live for com.yourcompany.Repro44366 at /private/var/containers/Bundle/Application/3531D0F4-91FB-4813-8990-3B15C8A252E4
Sep 22 10:23:10 Michaels-iPad installd[1079] <Notice>: 0x40115000 -[MIInstaller performInstallationWithError:]: Install Successful; Staging: 0.00s; Waiting: 0.00s; Preflight/Patch: 0.57s, Verifying: 0.33s; Overall: 1.31s
Sep 22 10:23:10 Michaels-iPad pkd[1184] <Warning>: releasing plug-in hold ECF44CB9-FCE4-45B2-8A16-947DC3AF30B9 at client's request
Sep 22 10:23:10 Michaels-iPad online-auth-agent[1207] <Error>:  SecTrustEvaluate  [leaf IssuerCommonName SubjectCommonName]
Sep 22 10:23:10 Michaels-iPad syncdefaultsd[1613] <Notice>: (Note ) marked "com.me.keyvalueservice" topic as "opportunistic" on <APSConnection: 0x15647750>
Sep 22 10:23:10 Michaels-iPad syncdefaultsd[1613] <Notice>: (Note ) marked "com.me.keyvalueservice" topic as "enabled" on <APSConnection: 0x15647750>
Sep 22 10:23:11 Michaels-iPad SpringBoard[1084] <Warning>: Installed apps did change.
	Added: {(
	)}
	Removed: {(
	)}
	Modified: {(
	    "com.yourcompany.Repro44366"
	)}
Sep 22 10:23:12 Michaels-iPad lockdownd[1068] <Error>: CFStringGetCString error in locklog
Sep 22 10:23:12 Michaels-iPad mobile_installation_proxy[1299] <Error>: 0x40197000 handle_connection: Could not receive request from host.
Sep 22 10:23:15 Michaels-iPad kernel[0] <Notice>: socketIsClosed sock_receive returned errno 54
Sep 22 10:23:16 Michaels-iPad notification_proxy[1301] <Error>: 0x40081000 -[MNPLockdownConnection receiveMessage]: lockdown_receive_message error!
Sep 22 10:23:26 Michaels-iPad routined[1074] <Error>: CoreLocation: Error occurred while trying to retrieve motion state update: CMErrorDomain Code:104
Comment 5 Brendan Zagaeski 2016-09-22 09:06:08 UTC
As a quick follow-up question, that Xcode log excerpt covers the full the scenario described in Comment 0 where the app is installed and launches but then it quits right away, correct?
Comment 6 Michael Rumpler 2016-09-22 09:15:45 UTC
Yes, there was no exception written to the log before.

However, because the log stated some strange messages with the date, I changed the timezone on iPad, Mac and PC to California now and now I get more in the device log:

Sep 22 02:05:53 Michaels-iPad installd[1079] <Notice>: 0x40115000 -[MIClientConnection _doBackgroundInstallationForPath:withOptions:completion:]: Install of "/var/mobile/Media/PublicStaging/Repro44366.iOS.app_sparse.ipa" type Developer (LSInstallType = (null)) requested by streaming_zip_conduit (pid 1359)
Sep 22 02:05:53 Michaels-iPad installd[1079] <Notice>: 0x40115000 -[MIInstaller performInstallationWithError:]: Installing <MIInstallableBundlePatch ID=com.yourcompany.Repro44366; Version=1.0, ShortVersion=1.0>
Sep 22 02:05:53 Michaels-iPad installd[1079] <Notice>: 0x40115000 -[MIInstallableBundlePatch applyPatchWithError:]: Attempting patch update of com.yourcompany.Repro44366 from 1.0 (1.0) to 1.0 (1.0)
Sep 22 02:05:54 Michaels-iPad installd[1079] <Notice>: 0x40115000 -[MIInstallableBundle performPreflightWithError:]: Setting skip watch app install flag
Sep 22 02:05:54 Michaels-iPad profiled[1173] <Notice>: (Note ) MC: Provisioning profiles changed
Sep 22 02:05:54 Michaels-iPad profiled[1173] <Notice>: (Note ) MC: Updating MIS trust...
Sep 22 02:05:54 Michaels-iPad securityd[1124] <Error>:  secTaskDiagnoseEntitlements MISSING keychain entitlements: no stored taskRef found
Sep 22 02:05:54 Michaels-iPad securityd[1124] <Error>:  secTaskDiagnoseEntitlements MISSING keychain entitlements: no stored taskRef found
Sep 22 02:05:54 Michaels-iPad installd[1079] <Error>:  SecTrustEvaluate  [leaf IssuerCommonName SubjectCommonName]
Sep 22 02:05:54 Michaels-iPad installd[1079] <Notice>: 0x40115000 -[MIInstallableBundle _refreshUUIDForContainer:withError:]: Data container for com.yourcompany.Repro44366 is now at /private/var/mobile/Containers/Data/Application/CC139C62-6FF4-42F7-BDD3-17CE372D411D
Sep 22 02:05:55 Michaels-iPad installd[1079] <Notice>: 0x40115000 -[MIContainer makeContainerLiveReplacingContainer:reason:withError:]: Made container live for com.yourcompany.Repro44366 at /private/var/containers/Bundle/Application/72BAA7E7-8BEA-46B7-8253-9B59EF879436
Sep 22 02:05:55 Michaels-iPad installd[1079] <Notice>: 0x40115000 -[MIInstaller performInstallationWithError:]: Install Successful; Staging: 0.00s; Waiting: 0.00s; Preflight/Patch: 0.70s, Verifying: 0.25s; Overall: 1.47s
Sep 22 02:05:55 Michaels-iPad pkd[1184] <Warning>: releasing plug-in hold 583E3E58-89B3-4A29-AABA-C65E46D84BDC at client's request
Sep 22 02:05:55 Michaels-iPad online-auth-agent[1207] <Error>:  SecTrustEvaluate  [leaf IssuerCommonName SubjectCommonName]
Sep 22 02:05:55 Michaels-iPad syncdefaultsd[1689] <Notice>: (Note ) marked "com.me.keyvalueservice" topic as "opportunistic" on <APSConnection: 0x17d42b60>
Sep 22 02:05:55 Michaels-iPad syncdefaultsd[1689] <Notice>: (Note ) marked "com.me.keyvalueservice" topic as "enabled" on <APSConnection: 0x17d42b60>
Sep 22 02:05:55 Michaels-iPad SpringBoard[1084] <Warning>: Installed apps did change.
	Added: {(
	)}
	Removed: {(
	)}
	Modified: {(
	    "com.yourcompany.Repro44366"
	)}
Sep 22 02:05:56 Michaels-iPad mobile_installation_proxy[1299] <Error>: 0x4029b000 handle_connection: Could not receive request from host.
Sep 22 02:05:57 Michaels-iPad lockdownd[1068] <Error>: CFStringGetCString error in locklog
Sep 22 02:06:01 Michaels-iPad com.apple.xpc.launchd[1] (lockdown.33888999524156.com.apple.mobile.mobile_image_mounter) <Warning>: com.apple.mobile.mobile_image_mounter: This daemon is not allowed to execute. Running anyway.
Sep 22 02:06:03 Michaels-iPad com.apple.debugserver-@(#)PROGRAM:debugserver  PROJECT:debugserver-340.3.124
	[1692] <Warning>: debugserver-@(#)PROGRAM:debugserver  PROJECT:debugserver-340.3.124
	 for armv7.
Sep 22 02:06:03 Michaels-iPad com.apple.debugserver-@(#)PROGRAM:debugserver  PROJECT:debugserver-340.3.124
	[1692] <Warning>: Connecting to com.apple.debugserver service...
Sep 22 02:06:03 Michaels-iPad com.apple.debugserver-@(#)PROGRAM:debugserver  PROJECT:debugserver-340.3.124
	[1692] <Warning>: Got a connection, waiting for process information for launching or attaching.
Sep 22 02:06:03 Michaels-iPad com.apple.debugserver-@(#)PROGRAM:debugserver  PROJECT:debugserver-340.3.124
	[1692] <Warning>: Sending AppProxy info: sequence no: 289, GUID: C7FE0A56-146F-4A4D-9333-07138C5E8D67.
Sep 22 02:06:03 Michaels-iPad com.apple.debugserver-@(#)PROGRAM:debugserver  PROJECT:debugserver-340.3.124
	[1692] <Error>: error: Unrecognized event type: .  Ignoring.
Sep 22 02:06:03 Michaels-iPad com.apple.debugserver-@(#)PROGRAM:debugserver  PROJECT:debugserver-340.3.124
	[1692] <Warning>: About to launch process for bundle ID: com.yourcompany.Repro44366
Sep 22 02:06:03 Michaels-iPad SpringBoard[1084] <Error>:  SecTrustEvaluate  [leaf IssuerCommonName SubjectCommonName]
Sep 22 02:06:03 Michaels-iPad SpringBoard[1084] <Error>:  SecTrustEvaluate  [leaf IssuerCommonName SubjectCommonName]
Sep 22 02:06:03 Michaels-iPad SpringBoard[1084] <Error>:  SecTrustEvaluate  [leaf IssuerCommonName SubjectCommonName]
Sep 22 02:06:03 Michaels-iPad securityd[1124] <Error>:  secTaskDiagnoseEntitlements MISSING keychain entitlements: no stored taskRef found
Sep 22 02:06:03 Michaels-iPad securityd[1124] <Error>:  secTaskDiagnoseEntitlements MISSING keychain entitlements: no stored taskRef found
Sep 22 02:06:03 Michaels-iPad amfid[1209] <Error>:  SecTrustEvaluate  [leaf IssuerCommonName SubjectCommonName]
Sep 22 02:06:03 Michaels-iPad kernel[0] <Notice>: xpcproxy[1693] Container: /private/var/mobile/Containers/Data/Application/CC139C62-6FF4-42F7-BDD3-17CE372D411D (sandbox)
Sep 22 02:06:03 Michaels-iPad com.apple.debugserver-@(#)PROGRAM:debugserver  PROJECT:debugserver-340.3.124
	[1692] <Warning>: In completion handler, got pid for bundle id, pid: 1693.
Sep 22 02:06:03 Michaels-iPad com.apple.debugserver-@(#)PROGRAM:debugserver  PROJECT:debugserver-340.3.124
	[1692] <Warning>: Got a connection, launched process /private/var/containers/Bundle/Application/72BAA7E7-8BEA-46B7-8253-9B59EF879436/Repro44366.iOS.app (pid = 1693).
Sep 22 02:06:03 Michaels-iPad com.apple.debugserver-@(#)PROGRAM:debugserver  PROJECT:debugserver-340.3.124
	[1692] <Warning>: 1 +0.000000 sec [069c/0c07]: Disabling breakpoints and watchpoints, and detaching from 1693.
Sep 22 02:06:03 Michaels-iPad com.apple.debugserver-@(#)PROGRAM:debugserver  PROJECT:debugserver-340.3.124
	[1692] <Warning>: 2 +0.000311 sec [069c/0c07]: error: ::ptrace (request = PT_THUPDATE, pid = 0x069d, tid = 0x2b07, signal = -1) err = Invalid argument (0x00000016)
Sep 22 02:06:03 Michaels-iPad com.apple.debugserver-@(#)PROGRAM:debugserver  PROJECT:debugserver-340.3.124
	[1692] <Warning>: 3 +0.001612 sec [069c/1b0b]: error: ::read ( -1, 0x402189ec, 18446744069414585344 ) => -1 err = Bad file descriptor (0x00000009)
Sep 22 02:06:03 Michaels-iPad com.apple.debugserver-@(#)PROGRAM:debugserver  PROJECT:debugserver-340.3.124
	[1692] <Warning>: Exiting.
Sep 22 02:06:03 Michaels-iPad com.apple.xpc.launchd[1] <Error>: assertion failed: 13G34: launchd + 85551 [AE14D564-B772-3E1A-96C5-DA53887FE78B]: 0x3
Sep 22 02:06:03 Michaels-iPad mobile_installation_proxy[1299] <Error>: 0x40197000 handle_connection: Could not receive request from host.
Sep 22 02:06:03 Michaels-iPad notification_proxy[1301] <Error>: 0x40081000 -[MNPLockdownConnection receiveMessage]: lockdown_receive_message error!
Sep 22 02:06:04 Michaels-iPad Repro44366.iOS[1693] <Warning>: Found new TLS offset at 176
Sep 22 02:06:04 Michaels-iPad Repro44366.iOS[1693] <Warning>: Could not register the assembly 'Xamarin.iOS': ObjCRuntime.RuntimeException: Wrapper type 'CloudKit.CKShareMetadata' is missing its native ObjectiveC class 'CKShareMetadata'.
	  at Registrar.DynamicRegistrar.OnRegisterType (Registrar.Registrar+ObjCType type) [0x00113] in /Users/builder/data/lanes/3426/6c3fee4d/source/xamarin-macios/src/ObjCRuntime/DynamicRegistrar.cs:787 
	  at Registrar.Registrar.RegisterTypeUnsafe (System.Type type, System.Collections.Generic.List`1[System.Exception]& exceptions) [0x010b5] in /Users/builder/data/lanes/3426/6c3fee4d/source/xamarin-macios/src/ObjCRuntime/Registrar.cs:1890 
	  at Registrar.Registrar.RegisterAssembly (System.Reflection.Assembly assembly) [0x00097] in /Users/builder/data/lanes/3426/6c3fee4d/source/xamarin-macios/src/ObjCRuntime/Registrar.cs:1933 
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: error: * Assertion at /Users/builder/data/lanes/3426/6c3fee4d/source/xamarin-macios/external/mono/mono/mini/debugger-agent.c:9864, condition `flags == 0' not met
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: Stacktrace:
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 
	Native stacktrace:
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 	0   Repro44366.iOS                      0x00065f11 mono_handle_native_sigsegv + 240
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 	1   libsystem_platform.dylib            0x2458585f _sigtramp + 42
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 	2   libsystem_pthread.dylib             0x24589b47 pthread_kill + 62
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 	3   libsystem_c.dylib                   0x244780c5 abort + 108
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 	4   Repro44366.iOS                      0x0011ff4c _ZL12log_callbackPKcS0_S0_iPv + 76
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 	5   Repro44366.iOS                      0x0011088b log_adapter + 170
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 	6   Repro44366.iOS                      0x0011a5cd monoeg_g_logv + 72
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 	7   Repro44366.iOS                      0x0011a6d9 monoeg_assertion_message + 32
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 	8   Repro44366.iOS                      0x00052273 debugger_thread + 19222
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 	9   Repro44366.iOS                      0x00112d51 inner_start_thread + 300
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 	10  libsystem_pthread.dylib             0x24588c7f <redacted> + 138
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 	11  libsystem_pthread.dylib             0x24588bf3 _pthread_start + 110
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 	12  libsystem_pthread.dylib             0x24586a08 thread_start + 8
Sep 22 02:06:06 Michaels-iPad Repro44366.iOS[1693] <Warning>: critical: 
	=================================================================
	Got a SIGABRT while executing native code. This usually indicates
	a fatal error in the mono runtime or one of the native libraries 
	used by your application.
	=================================================================
Sep 22 02:06:06 Michaels-iPad SpringBoard[1084] <Warning>: BSXPCMessage received error for message: Connection invalid
Sep 22 02:06:06 Michaels-iPad SpringBoard[1084] <Warning>: BSXPCMessage received error for message: Connection invalid
Sep 22 02:06:06 Michaels-iPad diagnosticd[1117] <Error>: error evaluating process info - pid: 1693, puniqueid: 1693
Sep 22 02:06:06 Michaels-iPad SpringBoard[1084] <Warning>: HW kbd: Failed to set (null) as keyboard focus
Sep 22 02:06:06 Michaels-iPad com.apple.xpc.launchd[1] (UIKitApplication:com.yourcompany.Repro44366[0x2af1][1693]) <Notice>: Service exited due to signal: Abort trap: 6
Sep 22 02:06:06 Michaels-iPad ReportCrash[1694] <Notice>: Formulating report for corpse[1693] Repro44366.iOS
Sep 22 02:06:06 Michaels-iPad SpringBoard[1084] <Warning>: Application 'UIKitApplication:com.yourcompany.Repro44366[0x2af1]' crashed.
Sep 22 02:06:06 Michaels-iPad UserEventAgent[1059] <Warning>: 33889117471030: id=com.yourcompany.Repro44366 pid=1693, state=0
Sep 22 02:06:06 Michaels-iPad ReportCrash[1694] <Warning>: Saved type '109(109_Repro44366.iOS)' report (1 of max 25) at /var/mobile/Library/Logs/CrashReporter/Repro44366.iOS-2016-09-22-020606.ips
Sep 22 02:06:14 Michaels-iPad DTFetchSymbols[1695] <Notice>: Found paths:
Sep 22 02:06:14 Michaels-iPad DTFetchSymbols[1695] <Notice>: /usr/lib/dyld
Sep 22 02:06:14 Michaels-iPad DTFetchSymbols[1695] <Notice>: /System/Library/Caches/com.apple.dyld/dyld_shared_cache_armv7s
Sep 22 02:06:14 Michaels-iPad DTFetchSymbols[1695] <Notice>: kCommand_ListFilesPlist
Sep 22 02:06:25 Michaels-iPad gputoolsd[1696] <Notice>: schedule invalidation <DYTransport 0x14d86460, error: lost transport connection (31)>
Sep 22 02:06:25 Michaels-iPad gputoolsd[1696] <Notice>: terminating daemon 0x14d86200
Sep 22 02:07:03 Michaels-iPad syslog_relay[1368] <Notice>: syslog_relay read 51 total bytes: 
	========================
	ASL is here to serve you
Sep 22 02:07:03 Michaels-iPad syslog_relay[1368] <Notice>: syslog_relay found the ASL prompt. Starting...
Sep 22 02:07:56 Michaels-iPad syncdefaultsd[1689] <Notice>: (Note ) marked "com.me.keyvalueservice" topic as "enabled" on <APSConnection: 0x17d42b60>

How can I access that "Saved type '109(109_Repro44366.iOS)' report (1 of max 25) at /var/mobile/Library/Logs/CrashReporter/Repro44366.iOS-2016-09-22-020606.ips"?

It's strange that the log reports a crash of the app, but when I press Home+Home, I still see it and can switch to it.
Comment 7 Michael Rumpler 2016-09-22 09:35:46 UTC
In Xcode / Devices / View Device Logs I don't see a crash
On the iPad in Settings / Privacy / Diagnostics & Usage I see No Diagnostic Data
Comment 8 Michael Rumpler 2016-09-29 09:07:06 UTC
I got my hands on an iPad Pro to test and there it worked.

Then I connected the old iPad4 and it failed. Then I rebooted the iPad and everything started to work as expected again. So it looks like something hang on the iPad itself.

I don't know if you have enough information from the logs I posted to find out what caused the error on the iPad, but I can't reproduce it anymore, so it's ok for me if you close this bug.

However, this bug raised two other problems:
- Tools / iOS / Device Log does not work reliably in Visual Studio
- the exception from Comment 6 was not written to the log when I used my original timezone of Vienna, Europe on the iPad

If there are no bugs filed for those problems, then you should do so.
Comment 9 bwright 2016-10-05 22:36:04 UTC
This is happening to me on an iPhone 6.  I'll try rebooting it and see if that is the issue, but it just began happening today after we switched Macs (I've setup the profiles and all that; the build occurs just fine).

Perplexed, I created a brand new Xamarin Forms app in Visual Studio, built it, and deployed/ran the solution, and it occurred on that, too.  However, I was able to simply reopen the blank app on my phone after it crashed during debug.

During debug crash, the log shows the following (only partial, let me know if the entire log would help):

Xamarin.Messaging.Client.MessagingClient Error: 0 : [2016-10-05 18:21:02.1772] An error occured on the receiver while executing a post for topic xvs/idb/4.2.0.703/launch-app and client vs2852bwrig
Xamarin.Messaging.Exceptions.MessagingRemoteException: An error occured on client IDB420703 while executing a reply for topic xvs/idb/4.2.0.703/launch-app ---> System.FormatException: Input string was not in a correct format.
  at System.Text.StringBuilder.AppendFormatHelper (System.IFormatProvider provider, System.String format, System.ParamsArray args) [0x000e9] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/text/stringbuilder.cs:1371 
  at System.String.FormatHelper (System.IFormatProvider provider, System.String format, System.ParamsArray args) [0x00011] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/string.cs:2978 
  at System.String.Format (System.String format, System.Object[] args) [0x00021] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/string.cs:2943 
  at System.Diagnostics.DiagnosticsTracer.Trace (System.String sourceName, System.Diagnostics.TraceEventType type, System.Exception exception, System.String format, System.Object[] args) [0x000ac] in <627b489c9ddd49728a42b1ec464bf330>:0 
  at System.Diagnostics.AggregateTracer+<>c__DisplayClass6_0.<Trace>b__0 (System.Diagnostics.DiagnosticsTracer tracer) [0x00000] in <627b489c9ddd49728a42b1ec464bf330>:0 
  at System.Collections.Generic.List`1[T].ForEach (System.Action`1[T] action) [0x00035] in <94fd79a3b7144c54b4cb162b50fc7761>:0 
  at System.Diagnostics.AggregateTracer.Trace (System.Diagnostics.TraceEventType type, System.Exception exception, System.String format, System.Object[] args) [0x0002a] in <627b489c9ddd49728a42b1ec464bf330>:0 
  at System.Diagnostics.ITracerExtensions.Error (System.Diagnostics.ITracer tracer, System.Exception exception, System.String format, System.Object[] args) [0x00000] in <627b489c9ddd49728a42b1ec464bf330>:0 
  at Xamarin.Messaging.IDB.MTouch+<RunAsync>d__8.MoveNext () [0x0026b] in <22db1dc2394c4ac18fc351e3a80b34a3>:0 
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/exceptionservices/exceptionservicescommon.cs:143 
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x00047] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:187 
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:156 
  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:128 
  at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () [0x00000] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:535 
  at Xamarin.Messaging.IDB.MTouch+<RunAsync>d__7.MoveNext () [0x0007b] in <22db1dc2394c4ac18fc351e3a80b34a3>:0 
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/exceptionservices/exceptionservicescommon.cs:143 
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x00047] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:187 
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:156 
  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:128 
  at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () [0x00000] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:535 
  at Xamarin.Messaging.IDB.MTouch+<LaunchAsync>d__5.MoveNext () [0x000bd] in <22db1dc2394c4ac18fc351e3a80b34a3>:0 
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/exceptionservices/exceptionservicescommon.cs:143 
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x00047] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:187 
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:156 
  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:128 
  at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () [0x00000] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:535 
  at Xamarin.Messaging.IDB.Handlers.LaunchAppMessageHandler+<RunMTouchAsync>d__17.MoveNext () [0x00148] in <22db1dc2394c4ac18fc351e3a80b34a3>:0 
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/exceptionservices/exceptionservicescommon.cs:143 
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x00047] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:187 
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:156 
  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:128 
  at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () [0x00000] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:535 
  at Xamarin.Messaging.IDB.Handlers.LaunchAppMessageHandler+<ExecuteOnPhysicalDeviceWithoutAssetsAsync>d__16.MoveNext () [0x00086] in <22db1dc2394c4ac18fc351e3a80b34a3>:0 
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/exceptionservices/exceptionservicescommon.cs:143 
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x00047] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:187 
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:156 
  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:128 
  at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () [0x00000] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:535 
  at Xamarin.Messaging.IDB.Handlers.LaunchAppMessageHandler+<ExecuteOnPhysicalDeviceAsync>d__14.MoveNext () [0x00189] in <22db1dc2394c4ac18fc351e3a80b34a3>:0 
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/exceptionservices/exceptionservicescommon.cs:143 
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x00047] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:187 
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:156 
  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:128 
  at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () [0x00000] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:535 
  at Xamarin.Messaging.IDB.Handlers.LaunchAppMessageHandler+<ExecuteAsync>d__12.MoveNext () [0x00118] in <22db1dc2394c4ac18fc351e3a80b34a3>:0 
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/exceptionservices/exceptionservicescommon.cs:143 
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x00047] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:187 
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:156 
  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in /private/tmp/source-mono-4.6.0/bockbuild-xamarin/profiles/mono-mac-xamarin/build-root/mono-x86/mcs/class/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:128 
  at System.Runtime.CompilerServices.TaskAwaiter`1[TResult].GetResult () [0x00000] in <94fd79a3b7144c54b4cb162b50fc7761>:0 
  at Xamarin.Messaging.Client.RequestHandler`2+<HandleAsync>d__5[TMessage,TResult].MoveNext () [0x0011a] in <3cc791dfde684ec285329f1caa709ddd>:0 
--- End of stack trace from previous location where exception was thrown ---
Comment 10 bwright 2016-10-05 22:37:18 UTC
ps... my iPhone is still 9.3.5, purposefully not updated to 10 yet to continue testing that version.  Everything was working fine previously.
Comment 11 bwright 2016-10-07 13:30:33 UTC
Update: updated my iPhone to iOS 10, rebooted, and a Hello World app works correctly when launching from VS debug.  Testing with a larger app and will report back.
Comment 12 bwright 2016-10-07 13:39:11 UTC
Getting a little further; my app now launches but almost immediately breaks with:

---------------------------------------------------
2016-10-07 09:34:46.456 MyAppiOS[516:87265] *** Assertion failure in -[UIApplication _runWithMainScene:transitionContext:completion:], /BuildRoot/Library/Caches/com.apple.xbs/Sources/UIKit/UIKit-3599.6.1/UIApplication.m:3679
Unhandled Exception:

Foundation.MonoTouchException: 

Thread finished: <Thread Pool> #5
The thread 'Unknown' (0x5) has exited with code 0 (0x0).
---------------------------------------------------


Same app works just fine on Droid / WinPhone.  Something appears to still be broken with iPhone + Xamarin -- please help, this is a client app with a deadline!
Comment 13 bwright 2016-10-07 13:50:53 UTC
I commented out some gesture event handlers assigned in a couple of my constructors and now get this error launching the app with debug:

Foundation.MonoTouchException: Objective-C exception thrown.  Name: NSInternalInconsistencyException Reason: Application windows are expected to have a root view controller at the end of application launch

The app crashes when attempting to launch it on the device outside of debug afterwards.
Comment 14 bwright 2016-10-07 16:23:49 UTC
During testing for the previous issue, I had removed my MainPage setting in App.cs.  Restoring that resolved the above issue concerning root view controller.
Comment 15 Brendan Zagaeski 2016-10-12 19:57:11 UTC
## Note to the Xamarin team

I noticed bug was recently assigned.  In case it's helpful, on associated Bug 44567, the QA team was apparently able to replicate the core error message shared across these 2 bugs ("System.FormatException: Input string was not in a correct format").  In short, Bug 44567, Comment 23 might be a good place to go for the initial verifications of candidate fixes for this issue.


I have kept these 2 reports separate so far due to the slight difference in the context of where the "Input string was not in a correct format" message appeared, but it seems quite possible that both bugs will have the same fix and this bug can eventually be marked as a duplicate of Bug 44567.
Comment 20 Brad Chase 2016-10-19 17:31:42 UTC
bwright@bizstream.com I am having the exact same problem now.  Just started after last update.  What did you do to fix it exactly?  I am trying desperately to get the app into Test Flight but all these problems are popping up.  ANY help at all would be welcomed.  Thanks!
Comment 21 Brendan Zagaeski 2016-10-19 19:01:47 UTC
## Status update

"Cycle 8 – Service Release 1" Beta (XamarinVS 4.2.1.15) builds that include a candidate fix for this issue have just been published Beta updater channel [1].

[1] https://developer.xamarin.com/recipes/cross-platform/ide/change_updates_channel/


If the original reporter of this bug (from Comment 0) gets a chance to verify that they no longer encounter the issue in their environment after this update, that would be perfect.  Thanks in advance!
Comment 22 Michael Rumpler 2016-10-20 06:10:33 UTC
For me rebooting the iPad fixed the problem as I wrote in #comment8. I cannot reproduce it anymore even without 4.2.1.15.
Comment 23 Kyle White 2016-10-27 13:30:12 UTC
per comment 22, marking verified

Note You need to log in before you can comment on or make changes to this bug.