Bug 44537 - XS 6.x branches are not reading XML documentation from 3rd party libraries
Summary: XS 6.x branches are not reading XML documentation from 3rd party libraries
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor (show other bugs)
Version: 6.1.0 (C8)
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: (C8SR1)
Assignee: Mike Krüger
URL:
: 45342 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-20 18:50 UTC by David Hathaway
Modified: 2016-10-13 12:38 UTC (History)
5 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description David Hathaway 2016-09-20 18:50:10 UTC
Steps to reproduce.

1. Create a new project
2. Add Json.NET via Nuget
3. Write code against the APIs, and look for code comments in intellisense

Expected Result

Intellisense shows comments/documentation from accompanying XML

Actual Result

Code comments are not showing in intellisense.
Comment 2 Matt Ward 2016-09-20 18:52:25 UTC
This works with Xamarin Studio 5.10 but not with 6.0 nor with 6.1.
Comment 3 xamarin-release-manager 2016-09-29 08:04:06 UTC
Fixed in version 6.2.0.644 (master)

Author: Mike Kr??ger
Commit: e0b5ce401fc1300733467c2ce6d432dfa519fa5a (mono/monodevelop)
Comment 4 Saurabh 2016-10-05 10:06:32 UTC
I can also reproduce this Issue with XS 6.1 (Build 5442). This is the screencast for the same: http://www.screencast.com/t/nuNsBzdaZuXc

I have checked this with latest master build (XS 6.2.0.725). I am getting comment in intellisense. This is the screencast for  the same: http://www.screencast.com/t/2dpIzxkS

Environment Info: https://gist.github.com/saurabh360/c9d0f09cb5cebb2eb98176388f3d3cbd

I'll verify this issue once fix will be merged in C8SR1
Comment 6 Mike Krüger 2016-10-13 08:24:09 UTC
*** Bug 45342 has been marked as a duplicate of this bug. ***
Comment 7 xamarin-release-manager 2016-10-13 11:17:52 UTC
Fixed in version 6.1.2.34 (cycle8)

Author: Lluis Sanchez
Commit: 9888915cf879f278f535e6987048637cf6923778 (mono/monodevelop)
Comment 8 Akhilesh kumar 2016-10-13 12:38:14 UTC
I have checked this issue with C8 build XS 6.1.2 (build 34) and this issue is working fine with C8 build also. So I am closing this issue.

Screencast: http://www.screencast.com/t/Uxu0r8RxtkWx


Thanks!

=== Xamarin Studio Enterprise ===

Version 6.1.2 (build 34)
Installation UUID: b62b65c1-43c6-4926-bdbe-9dc0be5d059f

=== Build Information ===

Release ID: 601020034
Git revision: 9888915cf879f278f535e6987048637cf6923778
Build date: 2016-10-13 08:09:35-04
Xamarin addins: 5d2cffc8e7a83cdf29e784b3e040bb5f2e7d06c8
Build lane: monodevelop-lion-cycle8

Note You need to log in before you can comment on or make changes to this bug.