Bug 44530 - [Generator] Seeing multiple error CS00**: Inconsistent accessibility errors building binding projects using class-parse
Summary: [Generator] Seeing multiple error CS00**: Inconsistent accessibility errors b...
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 7.1 (C9)
Hardware: Macintosh Mac OS
: High critical
Target Milestone: 7.1 (C9)
Assignee: Atsushi Eno
URL:
Depends on:
Blocks:
 
Reported: 2016-09-20 17:33 UTC by Peter Collins
Modified: 2016-10-06 13:16 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: cycle8

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Peter Collins 2016-09-20 17:33:12 UTC
I'm seeing a lot of new generator related build failures in certain binding projects now that class-parse has been enabled by default in C9. These errors are caused by seemingly newly reported inconsistent accessibility between classes, properties, paramaters, return types etc. This same project builds without issue using cycle8 based monodroid builds, which use jar2xml.

##### Steps to reproduce #####
1. Download, restore, and build the following project:
> https://github.com/xamarin/monodroid-samples/tree/master/android5.0/GoogleIO2014Master
##### Supplemental Info #####
Log File #1:	http://xqa.blob.core.windows.net/gist/log-95d9a11a6640490ab909978f376b0cbc.txt

##### Environment #####
Operating System: Mac OS X 10.11.5
Repo Name: monodroid.git
Branch Name: master
Build Revision: ab8f5949bf6f54ce79266ca54fe94045710c0fe6
Comment 1 Atsushi Eno 2016-10-05 07:31:43 UTC
I believe this breakage is related to the problem mentioned in this fix https://github.com/xamarin/java.interop/pull/83
Comment 2 Atsushi Eno 2016-10-05 15:52:37 UTC
https://github.com/xamarin/java.interop/pull/92 fixes the issue (regardless of whether we apply PR#83 fix or not).
Comment 3 Atsushi Eno 2016-10-06 08:38:45 UTC
PR #92 is merged.
Comment 4 Mohit Kheterpal 2016-10-06 13:16:50 UTC
i have checked this issue and able to reproduce this issue with master xamarin.android-7.0.99-90_b6aa7dae90029bbb9bccc29429e258fd4c1624b9

and observed that this issue has been fixed with master XA xamarin.android-7.0.99-117_5611972b4d3b08a8410265bda43c8c8d0871c4b8

Build output : https://gist.github.com/Mohit-Kheterpal/dea1a30e2c270c63b2b3d7f99e9217f9

Hence closing this issue by marking it as Verified.

thanks