Bug 44373 - [Cycle 8 Beta] [Full fix] iOS Designer initialization causes any already running iOS 10 simulator to hang
Summary: [Cycle 8 Beta] [Full fix] iOS Designer initialization causes any already runn...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS Designer (show other bugs)
Version: 6.1.0 (C8)
Hardware: PC All
: --- normal
Target Milestone: (C8SR0)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-09-15 15:50 UTC by Luis Aguilera
Modified: 2017-08-09 09:53 UTC (History)
10 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Luis Aguilera 2016-09-15 15:50:42 UTC
this bug will track the effort remaining for the 'full fix' as described in https://bugzilla.xamarin.com/show_bug.cgi?id=43566#c15
Comment 1 Kyle White 2016-09-15 19:47:34 UTC
Update per comment https://bugzilla.xamarin.com/show_bug.cgi?id=43566#c17 (this is now the bug to track the "mitigation" fix).
Comment 2 Kyle White 2016-09-15 19:51:50 UTC
I have verified on master that the mitigation effort is effective. Prior to the fix the issue was 100% reproducible in my experience. With this fix, I cannot reproduce anymore, I tried opening the designer multiple (~4) times and my already running iOS10 simulator is remaining responsive. 

I will again verify the issue on the release branch once it's merged. 

Build Information
Release ID: 602000494
Git revision: f6483f8a1c6d0790f2d8033a7e4d55e09b57a8bd
Build date: 2016-09-15 06:52:55-04
Xamarin addins: 3291a5df0a089370476aa9b24a4d4996e1df5479
Build lane: monodevelop-lion-master
Comment 3 Kyle White 2016-09-15 20:57:32 UTC
Also verified it with XVS master.
Comment 4 Kyle White 2016-09-20 18:27:14 UTC
Verified on release branch.

Build Information
Release ID: 601010012
Git revision: 8c26c5642182bdee0a1a0c976ca456565086212a
Build date: 2016-09-19 10:21:10-04
Xamarin addins: ee95a0d36b72ed02e773710ca124f0fdc53f86b7
Build lane: monodevelop-lion-cycle8-sr0
Comment 5 xamarin-release-manager 2017-08-09 09:53:16 UTC
Fixed in version 7.2.0.520 (d15-4)

Author: Alex Corrado
Commit: 58f56b5e92aacf0e2421f39dc6a8b9d7f20793dc (xamarin/ios-sim-sharp)
Included in Commit: 1fd75d9ebd78bcbb1de9c6997ed75c949d96085c (mono/monodevelop)