Bug 44348 - Archives-Window not displaying Version Code of iOS Archives in XS 6.1
Summary: Archives-Window not displaying Version Code of iOS Archives in XS 6.1
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: XI 10.0 (iOS10)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: (C9)
Assignee: Bugzilla
URL:
: 44350 44477 44694 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-15 05:26 UTC by Mark Fredrickson
Modified: 2016-12-05 11:28 UTC (History)
9 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Mark Fredrickson 2016-09-15 05:26:58 UTC
This is the same as bug 31066 but now it is occurring with XS 6.1, XCode 8 and SDK 10. I just updated everything and built my project and the version code is missing from the archives window. It still is uploaded to Apple so no problems there. Looks like a simple bug in XS 6.1.
Comment 1 emme.milani 2016-09-15 12:19:09 UTC
Here a workaround for fix the bug on version code:
1) archive for publish..
2) click Reveal in finder on the generated archive
3) right click on the ".xcarchive" in finder and click on "Show Package content"
4)double click on info.plist
5)Under Application properties add a key "CFBundleVersion" and set it to you version code. 
6)Sign in and distribute on archives in Xamarin studio
Comment 2 Mark Fredrickson 2016-09-15 15:02:58 UTC
That key is already in info.plist. It's just not showing in the Archives window. When you send the archive to Apple they see the bundle version just fine.
Comment 3 emme.milani 2016-09-15 15:10:40 UTC
Not true in my case.. the bundle version is not included in the info.plist. And the archive window show it correctly after you manually add it.
Comment 4 Jeffrey Stedfast 2016-09-15 16:22:22 UTC
PR @ https://github.com/xamarin/xamarin-macios/pull/839
Comment 5 Jeffrey Stedfast 2016-09-15 16:23:05 UTC
*** Bug 44350 has been marked as a duplicate of this bug. ***
Comment 6 Jeffrey Stedfast 2016-09-19 17:38:52 UTC
*** Bug 44477 has been marked as a duplicate of this bug. ***
Comment 7 narayanp 2016-09-27 14:34:36 UTC
I have checked this issue with XamarinStudio 6.2.0.619 and Xamarin.iOS 10.1.0.82 and observe that now the Version Code is displayed after building and archiving an iOS app.

Please refer to the screencast.

Screencast: http://www.screencast.com/t/YUd1pfEX

Environment Info:
gist: https://gist.github.com/lal360/86977abbb62719a1d20942e5a6e71e3e

Hence, I am closing this issue.


Thanks!!
Comment 8 Vincent Dondain [MSFT] 2016-10-14 16:43:36 UTC
*** Bug 44694 has been marked as a duplicate of this bug. ***
Comment 9 Lucas 2016-12-05 02:01:03 UTC
Any update on this?  Or how do I get XS 6.2?  I have a client wanting a new build and this is blocking me publishing my archive.
Comment 10 emme.milani 2016-12-05 11:28:08 UTC
To get 6.2 you must switch to beta channel or you can stay on stable and use my workaround on comment 1.