Bug 44330 - Can't edit storyboard with iOS Designer after editing with Xcode 8
Summary: Can't edit storyboard with iOS Designer after editing with Xcode 8
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS Designer (show other bugs)
Version: 6.1.0 (C8)
Hardware: Macintosh Mac OS
: Highest critical
Target Milestone: (C9)
Assignee: Bugzilla
URL:
: 44143 44358 44430 44441 44675 44754 44759 44883 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-14 21:48 UTC by Cyril Cathala
Modified: 2017-03-01 17:58 UTC (History)
27 users (show)

See Also:
Tags: potentialC8SR2
Is this bug a regression?: No
Last known good build:


Attachments
Partial workaround: Set storyboard to "Opens in Xcode 7.x" (194.58 KB, image/png)
2016-09-14 23:48 UTC, Brendan Zagaeski (Xamarin Support)
Details
Screen capture of the steps to replicate (1.92 MB, application/x-shockwave-flash)
2016-09-15 00:07 UTC, Brendan Zagaeski (Xamarin Support)
Details
Sample IDE logs and detailed version info for Comment 2 (5.43 KB, application/zip)
2016-09-15 00:11 UTC, Brendan Zagaeski (Xamarin Support)
Details

Description Cyril Cathala 2016-09-14 21:48:30 UTC
# Steps to reproduce
Edit a storyboard file with Xcode 8, manipulating outlets, stackviews, etc.

# Expected behavior
Get back to Xamarin Studio, everything is synced up and ready to be edited with the Xamarin iOS Designer.

# Actual behavior
Get back to Xamarin Studio, everything seems to be synced up but when launching the storyboard with iOS Designer, this message is displayed :
"This version does not have support for files saved in Xcode 8 format."

# Supplemental info (logs, images, videos)
This version does not have support for files saved in Xcode 8 format.
MDAddinsHash: ed25d008672663eeb9db55f1ccecb3c24d2fd3b2

[2016-09-14 15:22:46.5] INFO: Starting full reload...
[2016-09-14 16:10:10.9] INFO: Starting full reload...
[2016-09-14 16:10:14.4] INFO: Starting full reload...
[2016-09-14 17:25:02.4] INFO: Starting full reload...
[2016-09-14 17:53:30.3] INFO: Starting full reload...
[2016-09-14 23:24:16.3] INFO: Starting full reload...


# Test environment (full version information)
macOS 10.11.5
Xamarin Studio 6.1 (build 5441)
Xamarin.iOS 10.0.0.6
Comment 1 Brendan Zagaeski (Xamarin Support) 2016-09-14 23:48:00 UTC
Created attachment 17492 [details]
Partial workaround: Set storyboard to "Opens in Xcode 7.x"

At first glance, based on the specificity of the error message, this looks like it might primarily be an unfortunate oversight in the release notes.  It appears that the iOS designer is explicitly _not_ yet compatible with Xcode 8 format storyboards.

(Note that Xamarin's support for new iOS designer features is on a separate timeline from support for the iOS 10 and Xcode 8 _APIs_.)




## Partial workaround

1. Open the storyboard once more in Xcode 8.

2. Under the storyboard properties, change "Opens In" to "Xcode 7.x".

(See also the attached screenshot.)


As indicated by the dialog that will appear, this is only a partial workaround because it will remove Xcode 8 features:

> Saving for Xcode 7.x will close your document and data for Xcode 8.0
> features will be removed.



## Preliminary tally of additional users wondering about this restriction

- 2016/09/14 https://forums.xamarin.com/discussion/77604/this-version-does-not-have-support-for-files-saved-in-xcode-8-format/p1
- 2016/09/14 https://forums.xamarin.com/discussion/comment/220948/#Comment_220948
- 2016/09/14 https://forums.xamarin.com/discussion/comment/220822/#Comment_220822
- 2016/09/14 https://forums.xamarin.com/discussion/comment/220845/#Comment_220845
Comment 2 Brendan Zagaeski (Xamarin Support) 2016-09-15 00:07:51 UTC
Created attachment 17493 [details]
Screen capture of the steps to replicate
Comment 3 Brendan Zagaeski (Xamarin Support) 2016-09-15 00:11:32 UTC
Created attachment 17494 [details]
Sample IDE logs and detailed version info for Comment 2
Comment 4 Alan McGovern 2016-09-15 06:23:09 UTC
*** Bug 44143 has been marked as a duplicate of this bug. ***
Comment 5 Cyril Cathala 2016-09-15 06:43:38 UTC
Thank you for your quick reply.
The workaround does work, I'll stick with Xcode 7 compatibility for the time being, thank you!
Comment 6 Alan McGovern 2016-09-15 10:27:19 UTC
*** Bug 44358 has been marked as a duplicate of this bug. ***
Comment 7 Brendan Zagaeski (Xamarin Support) 2016-09-15 20:51:34 UTC
The release notes [1, 2] have now been updated to mention this restriction.

[1] https://developer.xamarin.com/releases/studio/xamarin.studio_6.1/xamarin.studio_6.1/
[2] https://developer.xamarin.com/releases/vs/xamarin.vs_4/xamarin.vs_4.2/
Comment 8 Brendan Zagaeski (Xamarin Support) 2016-09-17 00:38:45 UTC
*** Bug 44441 has been marked as a duplicate of this bug. ***
Comment 9 Alan McGovern 2016-09-20 15:47:08 UTC
*** Bug 44430 has been marked as a duplicate of this bug. ***
Comment 10 Alan McGovern 2016-09-23 12:07:46 UTC
*** Bug 44675 has been marked as a duplicate of this bug. ***
Comment 12 Alan McGovern 2016-09-27 13:10:44 UTC
*** Bug 44759 has been marked as a duplicate of this bug. ***
Comment 13 Alan McGovern 2016-09-27 13:12:35 UTC
*** Bug 44754 has been marked as a duplicate of this bug. ***
Comment 15 Alan McGovern 2016-10-01 20:43:02 UTC
*** Bug 44883 has been marked as a duplicate of this bug. ***
Comment 16 Sami Chamoun 2016-10-05 07:21:41 UTC
We are now using Xcode 8 and none of our storyboard's can be opened. Even when trying to create a new storyboard since the upgrade, these do not work either.

Unfortunately our files are stored on our Windows network and our mac does not have the relevant permissions to update "Opens in" value to Xcode 7.x.

We tried to create a new storyboard directly on our mac and save it as xcode 7.x but this does not appear to be working.

When will a patch for this be released? This is a major flaw that has halted our development entirely.
Comment 17 steveo275 2016-10-12 19:54:31 UTC
Sami, Xcode does have the opens in option.  It's in the File Inspector (like the properties window in VS) which is typically on the right.  Looks like a little file Icon near the top.  The "Opens in" option is about mid way down and defaults to "Latest Xcode (8.0).

XAMARIN:  I wish you would get your act together on the designer.  That way we wouldn't have to put the storyboard in Xcode to fix all the mistakes!  Specifically with constraints.  Unless you are using very basic constraints, designer is useless in VS.
Comment 18 dave.mast 2016-11-02 12:28:10 UTC
Any word on this, I am having an issue where I can build in the simulator, but build for an actual device fails with (The following, I even downloaded Xcode 7 and uninstalled Xcode 8......

This version does not have support for files saved in Xcode 8 format.

Contents of /Users/dmast/Library/Logs/XamarinStudio-6.0/iOSDesigner.2016-11-02__07-08-01.log:
MDAddinsHash: 19cdb28081bf28d9688698030abb96e04e391f69

[2016-11-02 07:22:59.9] INFO: Starting full reload...
[2016-11-02 07:23:00.1] INFO: Beginning the boostrap process for `/Applications/Xcode.app' / `/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk'
[2016-11-02 07:23:00.3] PERF: 	 - Waited 210ms for device to finish creating
[2016-11-02 07:23:00.3] PERF: 	 - Registering services: 8ms
[2016-11-02 07:23:00.5] PERF: 	 - Booting time: 148ms
[2016-11-02 07:23:00.5] PERF: 	 - Registering services: 0ms
[2016-11-02 07:23:00.9] PERF: 	 - Bridge loaded in 354.525ms
[2016-11-02 07:23:00.9] PERF: Total time for bootstrapping process: 805ms
Comment 19 Alan McGovern 2016-11-02 13:08:43 UTC
The iOS designer is not part of the build process so it is highly unlikely the designer is related to your issue, especially since it will refuse to open files stored in a format it cannot read/write.

If you have a build error then you'll need to file an issue against the Xamarin.iOS product and include the full diagnostic msbuild output so the problem can be diagnosed.
Comment 20 Alan McGovern 2016-11-04 00:29:28 UTC
This support has been merged to our master branch and will be shipped as part of the upcoming cycle 9 releases.
Comment 22 stefan.wagner 2017-01-19 16:00:29 UTC
I have the same problem in Visual Studio with the Version 

Xamarin   4.2.1.62 (680125b)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.
Xamarin.Android   7.0.2.37 (ce955cc)
Visual Studio extension to enable development for Xamarin.Android.
Xamarin.iOS   10.2.1.5 (44931ae)
Visual Studio extension to enable development for Xamarin.iOS.

Is this also fixed in a newer version?
Comment 23 Alan McGovern 2017-01-19 16:26:56 UTC
Full support for xcode 8+ has been released in all updater channels. Do try the latest stable release, or the builds in beta or alpha.
Comment 24 Alessandro Morvillo 2017-03-01 14:41:44 UTC
Same problem here. Storyboards or XIB cannot be edited from Xamarin Studio. Once the designer open the document, it goes on loading an undefined amount of time.

Xamarin is already patched to the lastest version.

Xamarin Studio version 6.2 build 1821.

Xamarin Studio Community
Version 6.2 (build 1821)
Installation UUID: 3bca550a-8e47-4d90-9959-1eb61d21fec0
Runtime:
	Mono 4.8.0 (mono-4.8.0-branch/e4a3cf3) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 408000495

NuGet
Versione: 3.5.0.0

Xamarin.Profiler
'/Applications/Xamarin Profiler.app' not found

Xamarin.Android
Non installato

Xamarin Android Player
Non installato

Apple Developer Tools
Xcode 8.2.1 (11766.1)
Build 8C1002

Xamarin.iOS
Version: 10.4.0.123 (Xamarin Studio Community)
Hash: 35d1ccd
Branch: cycle9
Build date: 2017-02-16 17:40:00-0500

Xamarin Inspector
Not Installed

Xamarin.Mac
Version: 3.0.0.393 (Xamarin Studio Community)

Build Information
Release ID: 602001821
Git revision: d41b6e51f3fa46a1943f2e31a778d28a7c73d069
Build date: 2017-02-17 15:18:19-05
Xamarin addins: 1363a8d943bab7700c93a97474060b6734aa7f94
Build lane: monodevelop-lion-cycle9

Operating System
Mac OS X 10.12.3
Darwin xxxx Darwin Kernel Version 16.4.0
    Thu Dec 22 22:53:21 PST 2016
    root:xnu-3789.41.3~3/RELEASE_X86_64 x86_64
Comment 25 Brendan Zagaeski (Xamarin Support) 2017-03-01 17:58:01 UTC
> Same problem here. Storyboards or XIB cannot be edited from Xamarin Studio.
> Once the designer open the document, it goes on loading an undefined amount
> of time.

That is a different symptom than described in Comment 0 where the Xamarin iOS designer used to show a "does not have support" message:

> # Actual behavior
> Get back to Xamarin Studio, everything seems to be synced up but when
> launching the storyboard with iOS Designer, this message is displayed :
> "This version does not have support for files saved in Xcode 8 format."

Please file a new bug report for any new symptoms you might be seeing that don't match up with the original description in Comment 0.  Thanks in advance!

Note You need to log in before you can comment on or make changes to this bug.