Bug 44273 - [Cycle 8] "An error occurred trying to load the page." appears in the "Project Properties > iOS Build" tab when not connected to a Mac
Summary: [Cycle 8] "An error occurred trying to load the page." appears in the "Projec...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: 4.2.0 (C8)
Hardware: PC Windows
: --- minor
Target Milestone: 4.2.1 (C8SR1)
Assignee: Emanuel
URL:
Depends on:
Blocks:
 
Reported: 2016-09-14 00:29 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2016-10-17 12:06 UTC (History)
9 users (show)

See Also:
Tags: BZRC8S1_C7SR1S1
Is this bug a regression?: Yes
Last known good build: Cycle 7 SR 1


Attachments
Screen capture showing the "bad" behavior (547.67 KB, application/x-shockwave-flash)
2016-09-14 00:29 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details
Screen capture showing the old "good" behavior (483.45 KB, application/x-shockwave-flash)
2016-09-14 00:29 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details
IDE logs and detailed version info (4.84 KB, application/zip)
2016-09-14 00:31 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details

Description Brendan Zagaeski (Xamarin Team, assistant) 2016-09-14 00:29:21 UTC
Created attachment 17451 [details]
Screen capture showing the "bad" behavior

[Cycle 8] "An error occurred trying to load the page." appears in the "Project Properties > iOS Build" tab when not connected to a Mac




## Workaround

Connect Xamarin for Visual Studio to a Mac, and then close and reopen the project properties.




## Regression status: Regression in Cycle 8 Stable compared to Cycle 7 SR 1

> BAD:  Xamarin 4.2.0.680 (c4382f5)
> GOOD: Xamarin 4.1.2.18  (fcbe082)




## Steps to replicate

1. Disconnect the Windows machine from the network (so that it doesn't have a chance to connect to a Mac agent).

2. Open a new or existing Xamarin.iOS project in Visual Studio.

3. Open the project properties and click the top-most tab.  That tab should say "iOS Build" and should appear directly above "iOS IPA Options".




## BAD Results


1. The tab title is empty where it would normally say "iOS Build"


2. Instead of showing any options, the tab instead shows an error message directly in the pane:

### Error message the first time the tab is accessed

> An error occurred trying to load the page.
> e41e8c8b-03c8-4f02-a8cf-e92418af80bf

### Subsequent times

> An error occurred trying to load the page.
> Unable to create the designer.  File is already opened in an incompatible editor.



## GOOD Results

The various "iOS Build" options appear on screen without error.




## Additional version info (brief)

Visual Studio 2015 Update 3 Enterprise
Windows 10 (64-bit)
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2016-09-14 00:29:58 UTC
Created attachment 17452 [details]
Screen capture showing the old "good" behavior
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2016-09-14 00:31:39 UTC
Created attachment 17453 [details]
IDE logs and detailed version info
Comment 4 xamarinbugzilla 2016-09-17 17:41:54 UTC
I'm getting this today now too. I have the same problem with

Xamarin 4.2.0.680 (c4382f5)

The workaround does not help me. I'm seeing this error even when connected to a mac. Disconnect/reconnect does not change the behavior. Also the order of items on the property page are different - the iOS items are last, rather than at the front of the list like they usually are :)
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2016-09-19 18:48:11 UTC
About Comment 4, that might in fact be a different issue.  The safest thing to do if you see symptoms that do not precisely match the original description on a bug is to file a new bug report.  The team can always mark the bug as a duplicate of this bug later on if that turns out to be appropriate.


In this case, I would recommend 3 additional data-gathering steps to include on your new bug:



- Does deleting the MEF component cache help?

%LOCALAPPDATA%\Microsoft\VisualStudio\1*.0\ComponentModelCache

(See also step 3 on https://developer.xamarin.com/guides/cross-platform/getting_started/visual_studio_with_xamarin/troubleshooting/uninstall-xamarinvs/)



- Be sure to collect and attach your log files from "Help > Xamarin > Zip Xamarin Logs", and be sure also to include your complete version information as usual [1].

[1] https://developer.xamarin.com/guides/cross-platform/troubleshooting/questions/howto-file-bug/



- If you get a chance, you can also try starting Visual Studio from the command line via `devenv /log` so that it will generate a `ActivityLog.xml`, and then also attach back that log:

%APPDATA%\Microsoft\VisualStudio\1*.0\ActivityLog.xml.



Thanks in advance.
Comment 6 xamarin-release-manager 2016-10-14 19:27:34 UTC
Fixed in version 4.2.1.6 (cycle8)

Author: Jose Gallardo
Commit: a398ffd6146cb6ff983fdc5e8609d324e3a8f070 (xamarin/XamarinVS)
Comment 7 Parmendra Kumar 2016-10-17 12:06:49 UTC
I have checked this issue with latest C8SR1 and Master build and observed that this issue is working fine.

C8SR1: Xamarin.VisualStudio_4.2.1.10_7dfd88ce14299e8598bc95fe6fdbf14d68e96211
Master: Xamarin.VisualStudio_4.3.0.80_27f5b58cf1408ec9a0537e39b63246370ce54f74

Screencast: http://www.screencast.com/t/jkVTdpLk

Hence closing this issue.

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.