Bug 44268 - [Cycle 8] "Unexpected libzip error: Inval" when building project that references Android Support Libraries on Windows if user name contains any accented characters
Summary: [Cycle 8] "Unexpected libzip error: Inval" when building project that referen...
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: 7.0 (C8)
Hardware: PC Windows
: Highest critical
Target Milestone: 7.0.x (C8SR0)
Assignee: Marek Habersack
URL:
: 44038 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-13 21:57 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2016-10-20 02:33 UTC (History)
3 users (show)

See Also:
Tags: XATriaged BZRC8S1_C7SR1S1
Is this bug a regression?: Yes
Last known good build: Cycle 7 SR 1


Attachments
Diagnostic MSBuild output (211.75 KB, text/plain)
2016-09-13 21:57 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details

Description Brendan Zagaeski (Xamarin Team, assistant) 2016-09-13 21:57:07 UTC
Created attachment 17447 [details]
Diagnostic MSBuild output

[Cycle 8] "Unexpected libzip error: Inval" when building project that references Android Support Libraries if user name contains any accented characters




## Regression status: Regression in Cycle 8 Stable compared to Cycle 7 SR 1

> BAD:  Xamarin 4.2.0.680 (c4382f5) (with Xamarin.Android 7.0.0.18 (0e59c36))
> GOOD: Xamarin 4.1.2.18  (fcbe082) (with Xamarin.Android 6.1.2.21 (1cf254d))




## Steps followed to replicate

1. Create a Windows username that includes a non-ASCII character.  (I used a single letter username "é" for my tests.)

2. Create a new "Visual C# > Android > Blank App (Android)" project.  (I created the project under the path `C:\source` for my tests.)

3. Add the "Xamarin.Android.Support.v4" (version 23.4.0.1) NuGet package.

4. Attempt to build the project.




## BAD Results on Cycle 8

The key error is:

> error XA5209: Reason: Unexpected libzip error: Inval



## GOOD Results on Cycle 7 SR 1

The build completes successfully (and so does packaging and signing into a .apk).




## Additional version info (brief)

Visual Studio 2015 Update 3 Enterprise
Windows 10 (64-bit)
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2016-09-13 22:01:04 UTC
*** Bug 44038 has been marked as a duplicate of this bug. ***
Comment 3 Marek Habersack 2016-09-16 12:16:48 UTC
Fix committed to LibZipSharp/master in commit eeba812d287c74e6d28cf5461f6fd62cff2f6963 (https://github.com/grendello/LibZipSharp/commit/eeba812d287c74e6d28cf5461f6fd62cff2f6963) but not yet included in xamarin-android or monodroid.
Comment 4 Marek Habersack 2016-09-16 12:51:18 UTC
Merged into monodroid/master, commit 780d661a4b93c1c080f06c9416c59f3a6e8adfd2
Comment 5 Marek Habersack 2016-09-16 18:02:32 UTC
Merged into xamarin-android/master, commit 3e41c40046e0c49e0291eaf08f16a9551a2d5305
Comment 6 Brendan Zagaeski (Xamarin Team, assistant) 2016-09-26 23:08:42 UTC
## Bookkeeping

It looks like this commit ended up being included in C8SR0 due to the update for LibZipSharp that was included for Bug 44184.  So this can optionally be verified against C8SR0 rather than C8SR1.  Thanks!
Comment 7 Saurabh 2016-10-05 08:59:51 UTC
I can also reproduce this Issue with Cycle8  build (XVS 4.2.0.680). This is the build output for the same: https://gist.github.com/saurabh360/ba0ba6b61d5add43ac20908c57ecb020

I have also checked it with latest C8SR0 build and it is working fine. This is the build output: https://gist.github.com/saurabh360/94585820835e95793f246c8a8288d145

Microsoft Visual Studio Professional 2013
Version 12.0.21005.1 REL
Microsoft .NET Framework
Version 4.6.01532

Xamarin   4.2.0.703 (3b7df6f)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.0.1.3 (96c7ba6)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.0.1.10 (ad1cd42)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 8 Brendan Zagaeski (Xamarin Team, assistant) 2016-10-20 02:33:25 UTC
## Bookkeeping

Adjusting target milestone to Cycle 8 SR 0 for precise bookkeeping based on the verification from Comment 7.

Thanks!

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.