Bug 44128 - Hard crash when closing designer window and changing API level
Summary: Hard crash when closing designer window and changing API level
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Designer (show other bugs)
Version: 6.1.0 (C8)
Hardware: PC Mac OS
: High critical
Target Milestone: (C8SR0)
Assignee: Jérémie Laval
URL:
Depends on:
Blocks:
 
Reported: 2016-09-08 20:57 UTC by Jérémie Laval
Modified: 2016-10-06 22:18 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jérémie Laval 2016-09-08 20:57:17 UTC
Repro steps

- Open Android solution
- Open a layout file and let it load
- Close layout file
- Go into project preferences and change project target API level (either through target framework or manually)
- XS crashes

Crash output: https://gist.github.com/garuma/beeb95f8b6ac694173fbda6d41853188

Reason: an event handler is not properly removed when closing the designer window.
Comment 1 xamarin-release-manager 2016-09-08 21:04:22 UTC
Fixed in version 6.2.0.474 (master)

Author: J??r??mie Laval
Commit: 70ef4267d5958fdfb22bf8f96d8388c30435a29b (xamarin/md-addins)
Included in Commit: d7a6c37efbf2a68471ca00160405653fa55a9d83 (mono/monodevelop)
Comment 2 Kyle White 2016-09-15 21:06:35 UTC
To reproduce you need to again open the layout file after changing the target API level  as described in the steps above. 

I have verified the issue is fixed on master. We will again verify and mark the bug as such when it's merge to release branch.
Comment 3 Danish Akhtar 2016-09-19 07:26:56 UTC
I have checked this issue with C8Sr0 XS 6.1.1(build 5) on both mac and windows and observed that now this issue is not exists.

I am successfully able to reopen the layout file after changing the target API level. Here is the screencast for the same: http://www.screencast.com/t/uhdACeVZjw

Env info for mac: https://gist.github.com/saurabh360/8e0323805d6f899166b0f8d642ac88a7
Env info for Win: https://gist.github.com/saurabh360/d26d557267683e1e962bf7c592a76967

Hence closing this issue.
Comment 4 xamarin-release-manager 2016-09-19 09:39:10 UTC
Fixed in version 6.1.1.6 (cycle8-sr0)

Author: J??r??mie Laval
Commit: 76be068f546b6e12d60204f78d0ed2facd4c3da8 (xamarin/md-addins)
Included in Commit: c085b3b9ddec372b8aae6cf2313a1b9eb7f5f81c (mono/monodevelop)
Comment 5 xamarin-release-manager 2016-10-06 22:18:35 UTC
Fixed in version 6.1.2.27 (cycle8)

Author: J??r??mie Laval
Commit: 76be068f546b6e12d60204f78d0ed2facd4c3da8 (xamarin/md-addins)
Included in Commit: b2677b526de69bd9f7b777a987a6501a1256524a (mono/monodevelop)