Bug 44105 - User is getting error when running Android application with Release mode in VS
Summary: User is getting error when running Android application with Release mode in VS
Status: RESOLVED DUPLICATE of bug 46279
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android (show other bugs)
Version: 4.2.0 (C8)
Hardware: PC Windows
: Highest blocker
Target Milestone: 4.2.0 (C8)
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2016-09-08 11:58 UTC by Danish Akhtar
Modified: 2016-11-02 01:16 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: XVS 4.2.0.660

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 46279

Comment 1 Jose Gallardo 2016-09-08 14:08:15 UTC
It's an issue with the Deployment target.
@Dean  can you please take a look?

Thanks!
Comment 2 dean.ellis 2016-09-08 14:19:59 UTC
work around is to turn off AndroidManagedSymbols for now. 
This is to do with the mkbundled mono-symbolicate not working.
Comment 3 Jose Gallardo 2016-09-08 14:31:57 UTC
@danish can you please try to reproduce the issue with 4.2.0.660 ?

I wasn't able to reproduce the issue even with latest bits (4.2.0.673).
Comment 4 Jose Gallardo 2016-09-08 14:32:46 UTC
My bad, I mean can you try to reproduce the issue with 4.2.0.664?

Thanks!
Comment 6 Jose Gallardo 2016-09-08 18:24:14 UTC
As we couldn't repro, marking it as Resolved - Not_Reproducible.
Comment 8 Jose Gallardo 2016-09-09 13:18:02 UTC
Thanks @narayanp, I've also tried with the attached project and it deploys successfully with current Beta (4.2.0.675) for either Debug or Release configurations.
Comment 9 Brendan Zagaeski (Xamarin Team, assistant) 2016-11-02 01:16:14 UTC
I will mark this bug as a duplicate of a new bug I have filed that precisely characterizes the appearance of this problem in the XamarinVS 4.2.0.719 version.  As mentioned there, my suspicion is that this problem might be related to the particular build environment (the particular computer) that was used to build this exact problematic version of the Xamarin.VisualStudio installer.  I suspect that could explain why the issue has somewhat "mysteriously" appeared and disappeared both in this bug (Bug 44105) as well as in one other report of the problem (Bug 43833).

*** This bug has been marked as a duplicate of bug 46279 ***