Bug 44021 - No way to set sticker icons source in iMessage extension
Summary: No way to set sticker icons source in iMessage extension
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: 6.1.0 (C8)
Hardware: Macintosh Mac OS
: High major
Target Milestone: (C8SR0)
Assignee: Vincent Dondain [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2016-09-06 13:57 UTC by Oleg Demchenko
Modified: 2016-09-07 14:30 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: No
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Oleg Demchenko 2016-09-06 13:57:03 UTC
Even if we have support for iMessages assets catalog there's no way to set sticker icons source in XS.

I suppose this functionality should be implemented in Info.plist editor.

This how it's implemented in Xcode 8 beta:
http://screencast.com/t/m4C4PsodVVh

XS Version 6.1 (build 5110)
Comment 1 Oleg Demchenko 2016-09-06 16:49:56 UTC
Bumping priority, since it's impossible to submit appex without image assets to the AppStore.
Comment 2 Lluis Sanchez 2016-09-06 16:58:55 UTC
It looks like implementing support for this is not trivial, and beyond the scope of Cycle 8. If this problem is a blocker for submitting applications, maybe we should consider working on a fix for SR0. Jeff?
Comment 3 Vincent Dondain [MSFT] 2016-09-06 18:13:37 UTC
Oops my bad, I missed that. Fixing that isn't trivial but not too complex either, I'm gonna fix it ASAP and we'll see where we can ship it. SR0 sounds reasonable.
Comment 4 xamarin-release-manager 2016-09-06 21:29:16 UTC
Fixed in version 6.1.0.5115 (xcode8-templates)

Author: Vincent Dondain
Commit: 6d4c4c1313d4907926159cfad6dea3deb00d5903 (xamarin/md-addins)
Included in Commit: 78abc4e717bb11a68a98011aa1832b9586afdf00 (mono/monodevelop)
Comment 5 xamarin-release-manager 2016-09-06 22:40:57 UTC
Fixed in version 6.1.0.5433 (cycle8)

Author: Vincent Dondain
Commit: 6d4c4c1313d4907926159cfad6dea3deb00d5903 (xamarin/md-addins)
Included in Commit: 6c75bc1d4ed7b307d8b520127035a302eb2897e2 (mono/monodevelop)
Comment 6 Naqeeb 2016-09-07 14:21:29 UTC
I have checked this issue with build XamarinStudio-6.1.0.5115 and observed that it is working fine. I am getting option 'Source' for 'iMessage App Icon'. Below is the screencast for the same.

Screencast: http://www.screencast.com/t/gAdDJfSdK
Environment info: https://gist.github.com/NaqeebAnsari/f2cac2f995557dd437e92c040ba4afaf
Comment 7 Naqeeb 2016-09-07 14:30:14 UTC
I have checked this issue with C8 build i.e. XamarinStudio-6.1.0.5434_2eac59d2a9b1b330759bd78bc8f2f42eb12f2b74 and observed that it is working fine. I am getting option 'Source' for 'iMessage App Icon' in info.plist editor. Below is the screencast for the same.

Screencast: http://www.screencast.com/t/CtqFzTQnOg
Environment info: https://gist.github.com/atin360/413a61104cb2a60edc7d83d4eae06d4d

Hence closing this issue.