Bug 44006 - Mapbox SDK component version 4.1.1.0 causes device builds to fail with "Failed to compile the generated registrar code ... error: property with 'copy' attribute must be of object type"
Summary: Mapbox SDK component version 4.1.1.0 causes device builds to fail with "Faile...
Status: RESOLVED FIXED
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components (show other bugs)
Version: Production (addons.xamarin.com)
Hardware: PC Mac OS
: --- major
Target Milestone: ---
Assignee: Jon Dick
URL:
Depends on:
Blocks:
 
Reported: 2016-09-06 06:24 UTC by arnebalduyck
Modified: 2017-09-28 15:16 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: Mapbox SDK 4.1.0.0

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description arnebalduyck 2016-09-06 06:24:54 UTC
Device build failes with mapbox sdk on 9.3 (xamarin mapbox sdk component 4.1.1.0)
To reproduce: just build the demo associated with the component.

Please, is it possible to opensource the mapbox bindings. 
This breaks development for us and there is no way to fix this!!

------------------------------------
MTOUCH: error MT4109: Failed to compile the generated registrar code. Please file a bug report at http://bugzilla.xamarin.com

registrar.m:9285:12: error: property with 'copy' attribute must be of object type
@optional @property (nonatomic, copy, readonly) void * identifier

@protocol MGLFeature
    @optional @property (nonatomic, copy, readonly) void * identifier;
    @optional @property (nonatomic, copy, readonly) NSDictionary * attributes;
    @optional -(void *) attributeForKey:(NSString *)p0;

@end
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2016-09-10 00:52:59 UTC
> Please, is it possible to opensource the mapbox bindings. 

That component is by chance already open source:

https://github.com/xamarin/XamarinComponents/tree/master/XPlat/Mapbox




## Regression status: Appears to be a regression in the Mapbox component itself, perhaps due to an underlying bug in the version of Xamarin.iOS that was used to build the component?



### Mapbox SDK component 4.1.1.0 (August 21, 2016)

#### With Xcode 7.3

BAD: Xamarin.iOS 10.0.0.4 (xcode8:     d1ee3ba)
BAD: Xamarin.iOS 9.8.2.22 (cycle7-sr1: f37444a)
BAD: Xamarin.iOS 9.6.2.4  (cycle6-xi:  d8bedd0)
BAD: Xamarin.iOS 9.1.0.27 (cycle5-sr5: 1f068b4) + Mono 4.0.5 (1d8d582)


#### With Xcode 6.4

BAD: Xamarin.iOS 9.1.0.27 (cycle5-sr5: 1f068b4) + Mono 4.0.5 (1d8d582)




### Mapbox SDK component 4.1.0.0 (July 16, 2016)

#### With Xcode 7.3

GOOD: Xamarin.iOS 10.0.0.4 (xcode8:     d1ee3ba)




## Steps followed to replicate

1. Create a new template iOS app.

2. Add the "Mapbox SDK" component.

3. Open the "samples\MapBoxSampleiOS" project from within the un-zipped component.

4. Attempt to build the sample in the "Debug|iPhone" configuration.




## Results

> mapboxsdk-4.1.1.0/samples/MapboxSampleiOS/MapboxSampleiOS/obj/iPhone/Release/mtouch-cache/64/registrar.m:789:12: error: property with 'copy' attribute must be of object type
> 				        @optional @property (nonatomic, copy, readonly) void * identifier;
> 				                  ^ 
> 				1 error generated.
> MTOUCH: error MT4109: Failed to compile the generated registrar code. Please file a bug report at http://bugzilla.xamarin.com
Comment 2 Jon Dick 2017-09-28 15:16:30 UTC
Should be fixed in newer versions