Bug 43993 - iOS: ListView size does not return to normal after keyboard disappears
Summary: iOS: ListView size does not return to normal after keyboard disappears
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 44604 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-05 03:52 UTC by adrianknight89
Modified: 2016-12-20 01:44 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
repro (164.82 KB, application/zip)
2016-09-05 03:52 UTC, adrianknight89
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description adrianknight89 2016-09-05 03:52:45 UTC
Created attachment 17330 [details]
repro

Please see repro.

When keyboard shows for an entry, it resizes the listview. When the keyboard is hidden, listview size does not return to normal on iOS.

Steps to reproduce:

1) Observe that item 99 on the list can be seen at the bottom
2) Hit entry area to display keyboard
3) Hide keyboard
4) Observe that several items at the bottom of the list cannot be navigated to because the listview size has increased.
Comment 1 adrianknight89 2016-09-05 05:35:49 UTC
If you put the page in a navigation page AND the navigation bar is visible, then this issue is not present. However, I need to hide the navigation bar so for me this is a big issue.
Comment 2 adrianknight89 2016-09-05 17:11:31 UTC
The issue was introduced in 2.3.2.118-pre1. If you revert to 2.3.1.114, then you won't see it.
Comment 3 adrianknight89 2016-09-06 21:41:00 UTC
This PR fixes the issue: https://github.com/xamarin/Xamarin.Forms/pull/333
Comment 4 Rui Marinho 2016-10-04 16:33:19 UTC
This should be fixed in 2.3.2 hot fix 2, and 2.3.3-pre4
Comment 5 Matthew 2016-10-18 14:23:08 UTC
You really saved my bacon on fixing this, just discovered it today in stable!
Comment 6 Parmendra Kumar 2016-11-03 13:02:09 UTC
I have also checked this issue with Xamarin.Forms 2.3.3-pre3 and its working fine.

Hence closing this issue.
Comment 7 Samantha Houts [MSFT] 2016-12-20 01:44:23 UTC
*** Bug 44604 has been marked as a duplicate of this bug. ***