Bug 43975 - The SearchBar doesn't display on Android N
Summary: The SearchBar doesn't display on Android N
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android (show other bugs)
Version: 2.3.1
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 44171 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-02 18:30 UTC by jmgomez
Modified: 2018-03-26 09:10 UTC (History)
18 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 43975 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description jmgomez 2016-09-02 18:30:54 UTC
Android N is out there and it seems like the latest version of Xamarin.Forms is not compatible with it.
Comment 1 williamd 2016-09-16 17:50:27 UTC
Can confirm that the SearchBar does not display when using Xamarin.Forms 2.3.2.127 with Android Nougat.
Comment 2 williamd 2016-09-19 13:37:51 UTC
Did some digging and it appears to be related to the Android issue: https://code.google.com/p/android/issues/detail?id=221304&q=reportedby%3DDeveloper%20-has%3Amergedinto%20type%3Adefect&colspec=ID%20Status%20Priority%20Owner%20Summary%20Stars%20Reporter%20Opened&start=500

You can work around this issue by giving your SearchBar an explicit HeightRequest value.
Comment 3 Paul DiPietro [MSFT] 2016-10-03 15:42:19 UTC
*** Bug 44171 has been marked as a duplicate of this bug. ***
Comment 4 Paul DiPietro [MSFT] 2016-10-03 15:44:53 UTC
This is a Google issue as linked above but I'll set to confirmed for now to keep track of the status of this.
Comment 5 dpedrinha 2017-08-30 05:04:24 UTC
Same problem here. Which would be the default HeightRequest?
Comment 6 Mikalai Daronin 2017-08-30 06:30:40 UTC
@dpedrinha 42 on Android, probably.
Comment 8 christopher 2018-03-26 09:10:32 UTC
Setting a HeightRequest does not seem necessary any longer using Xamarin.Forms 2.5.0. Tested with a Nexus 6 and Android 7.1.1.