Bug 43948 - Unable to open Main.axml file in VS.
Summary: Unable to open Main.axml file in VS.
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android Designer (show other bugs)
Version: 4.2.0 (C8)
Hardware: PC Windows
: High major
Target Milestone: 4.2.1 (C8SR1)
Assignee: Bugzilla
URL:
: 44383 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-01 17:21 UTC by Naqeeb
Modified: 2016-10-14 15:42 UTC (History)
10 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: Stable XVS 4.1.2.18


Attachments

Description Naqeeb 2016-09-01 17:21:31 UTC
Created attachment 17296 [details]
ZipXamarinLogs

Steps to reproduce:
Steps to reproduce:
1. Open VS and create Single-View App(Android) project.
2. Open Main.axml file
2. Switch to 'Source' tab. It will open successfully.
4. Again switch back to'Designer' tab. it will also open successfully.
5. Repeat steps 3 and 4 multiple times.
6. Observed that designer does not open and It is continuously show in-progress bar.
7. Create new Single-View App(Android) project and try to open Main.axml file

Actual Result: Also designer does not open for new created Single-View App(Android) project and  It is continuously show in-progress bar.

Expected Result: User should able to open designer successfully.

screencast: http://www.screencast.com/t/91OO3RCVM34V

Regression Status: This issue does not exist with stable XVS 4.1.2.18

Environment info: https://gist.github.com/Rajneesh360Logica/db26ffc88c67d08826ccb35c4dfcc707
Comment 1 Jérémie Laval 2016-09-15 19:46:04 UTC
*** Bug 44383 has been marked as a duplicate of this bug. ***
Comment 3 Michael Veroukis 2016-09-21 16:36:53 UTC
I'm getting this too. Is there a work-around or an ETA on when this will get fixed? It makes working with layout files rather difficult. I have to run my app to see how it'll look. Really slows me down. Wish you guys would add an "Import Layout from Android Studio" option.
Comment 4 Jose Gallardo 2016-10-14 13:28:09 UTC
Fixed on C8SR1 and master
Comment 5 Akhilesh kumar 2016-10-14 15:42:03 UTC
I have checked this issue with C8SR1 and master build, now this issue does not exist. So I am closing this issue. Designer opens successfully on switching between Source and Designer tab.

Screencast: http://www.screencast.com/t/Mk3fsPF8

So I am closing this issue.

Environment info:

Microsoft Visual Studio Enterprise 2015
Version 14.0.25425.01 Update 3
Microsoft .NET Framework
Version 4.6.01055

C8 Build info:

Xamarin   4.2.0.759 (744caec)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.0.2.20 (821af8b)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.0.1.36 (043c11a)
Visual Studio extension to enable development for Xamarin.iOS.

Master build info:

Xamarin   4.3.0.59 (04d9513)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.0.99.126 (89f846c)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.1.0.135 (0760023)
Visual Studio extension to enable development for Xamarin.iOS.

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 43948 on Developer Community if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: