This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 43867 - Numeric keyboard shows text / default keyboard when back button is hit
Summary: Numeric keyboard shows text / default keyboard when back button is hit
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android (show other bugs)
Version: 2.3.2
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-30 02:03 UTC by adrianknight89
Modified: 2017-01-30 19:54 UTC (History)
5 users (show)

See Also:
Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
repro (67.84 KB, application/zip)
2016-08-30 02:03 UTC, adrianknight89
Details
correct-repro (60.10 KB, application/zip)
2016-08-30 02:17 UTC, adrianknight89
Details

Description adrianknight89 2016-08-30 02:03:05 UTC
Created attachment 17250 [details]
repro

Please see repro.

Steps to produce:

1) Tap on Entry to bring into focus
2) Numeric keyboard shows
3) Hit on back button to dismiss keyboard
4) While dismissing, keyboard changes to text / default keyboard.
5) If you can't observe this, start from step 1 until you observe.

You might need to follow these steps anywhere between 1 - 10 times to see the issue. In my actual app, it happens almost all the time. This is a serious problem for me, and I'd like to see a fix soon.
Comment 1 adrianknight89 2016-08-30 02:17:29 UTC
Created attachment 17251 [details]
correct-repro

please ignore my first repro as it was the incorrect project.

i attached the correct repro for you to see.
Comment 2 adrianknight89 2016-09-01 07:04:54 UTC
I'm thinking the issue might be with Mono.Android. Keyboard type changes after
 
public virtual bool OnKeyPreIme([GeneratedEnum] Keycode keyCode, KeyEvent e);

is called in Xamarin.Forms.Platform.Android.EntryEditText.
Comment 3 John Hardman 2016-10-21 16:18:28 UTC
With XF 2.3.2.127, I am finding that Android is showing the default keyboard after Entry is set to use the numeric keyboard. No need to hit the Back button etc.

The problem is not seen on iOS, WinRT or UWP, only on Android.
Comment 4 adrianknight89 2016-12-30 02:04:20 UTC
See https://github.com/xamarin/Xamarin.Forms/pull/663

@John, I haven't tested your scenario. Looks like it's a different issue. If you have a repro, please file another bug.
Comment 5 Samantha Houts 2017-01-30 19:54:11 UTC
Should be fixed in 2.3.5-pre1. Thank you!

Note You need to log in before you can comment on or make changes to this bug.