Bug 43742 - Inconsistency of netstandard mappings to Xamarin.iOS in NuGet shipped with VS/XS on C8
Summary: Inconsistency of netstandard mappings to Xamarin.iOS in NuGet shipped with VS...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NuGet (show other bugs)
Version: 6.1.0 (C8)
Hardware: All All
: High major
Target Milestone: (C8)
Assignee: Matt Ward
URL:
Depends on:
Blocks:
 
Reported: 2016-08-25 11:05 UTC by Alexander Köplinger [MSFT]
Modified: 2016-09-09 05:49 UTC (History)
7 users (show)

Tags: C8SR1
Is this bug a regression?: Yes
Last known good build: C7SR1

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Alexander Köplinger [MSFT] 2016-08-25 11:05:12 UTC
According to https://bugzilla.xamarin.com/show_bug.cgi?id=43695#c5 the NuGet 3.4 that ships with C8 in XS/VS maps the products to netstandard1.5. Apparently we have communicated publicly that we support netstandard1.6 (though I can't find a definite announcement, the https://blog.xamarin.com/net-standard-library-support-for-xamarin/ blog doesn't say which version).

We need to decide whether we should fix this by a) modifying the mapping in the NuGet XS ships or b) ignore it and wait until we roll out NuGet 3.5
Comment 1 Marek Safar 2016-08-25 12:09:38 UTC
I cannot find any explicit 1.6 confirmation but netstandard pages has it as 1.6 (if I decoded that correctly) and our blog post highlight 1.6 everywhere too.
Comment 2 Mikayla Hutchinson [MSFT] 2016-08-30 16:07:00 UTC
Yes, we should definitely update NuGet before C8 release - ideally 3.5 if it's out, else 3.5 RC. NuGet 3.4.x has outdated netstandard support.
Comment 4 Matt Ward 2016-09-06 08:11:34 UTC
NuGet versions currently have the following .NETStandard mappings for the Xamarin frameworks:

NuGet 2.12 => .NETStandard 1.6
NuGet 3.4.3 => .NETStandard 1.5
NuGet 3.4.4 => .NETStandard 1.5
NuGet 3.5 rc1 => .NETStandard 1.7


NuGet 2.12:

https://github.com/NuGet/NuGet.Client/blob/49234c230df0fc01868d8b90e667af89be8cc4f6/src/NuGet.Core/NuGet.Frameworks/DefaultFrameworkMappings.cs#L425

NuGet 3.4.3:

https://github.com/mrward/NuGet.Client/blob/release-3.4.3-monodevelop/src/NuGet.Core/NuGet.Frameworks/DefaultFrameworkMappings.cs#L417


Updating Xamarin Studio to NuGet 3.5 rc1 will most likely involve changes to the NuGet addin since I know of at least one breaking change to the NuGet API that was made in 3.4.4 so I expect there will be more in 3.5.

A less risky change would be to update the mappings in the build of NuGet 3.4.3 that ships with Xamarin Studio. This would mean Xamarin Studio would have different behaviour to NuGet 3.4 in Visual Studio.
Comment 7 xamarin-release-manager 2016-09-08 16:18:02 UTC
Fixed in version 6.1.0.5439 (cycle8)

Author: Matt Ward
Commit: 4253fd7a57af6b461554335110f63188f477aaca (mono/monodevelop)