Bug 43735 - Multiple Swipe on ContextActions
Summary: Multiple Swipe on ContextActions
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.1
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-25 08:47 UTC by Thimo
Modified: 2017-03-16 01:15 UTC (History)
9 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Thimo 2016-08-25 08:47:08 UTC
It is possible to swipe multiple ListView Cells to see the context actions.

Steps to reproduce:
1. ListView with ContextActions
2. Swipe multiple Cells at the same time
3. tap the context action button
4. Action is applied to other cells then the selected one


Expectation:
- It shouldn't be possible to swipe more than one cell at a time
Comment 1 Xet 2016-09-15 05:59:17 UTC
I can somewhat confirm.
On iOS10 devices, when trying to swipe the second cell, it crashes and raises an System.ArgumentNullException with the message:
Value cannot be null.
Parameter name: gestureRecognizer

It originates from UIKit.UIView.RemoveGestureRecognizer, from what I can tell.

Using Forms 2.3.2.127 it seems to work on iOS 9 devices.
Comment 2 Marius Kahmen 2016-09-15 11:55:33 UTC
@Xet: you were supposed to open a new bug for the crash. It's important. couldn't find one... did you do it?
Comment 3 Xet 2016-09-15 15:46:24 UTC
No I did not, since I figured that the issues reported in the bug is directly related to the crash.
Comment 4 Hector 2016-09-22 17:31:47 UTC
I confirm the behaviour described by @Xet on iOS 10 devices.
Comment 5 Chris King 2016-10-05 18:18:54 UTC
Reproduced Xet. Opened "ContextActions List Gallery" on iOS > Open context actions for one row > Try open context actions for another. Observed exception.
Comment 6 adrianknight89 2016-10-12 05:06:46 UTC
The second bug you all are describing should soon be fixed. See https://github.com/xamarin/Xamarin.Forms/pull/442. I'm wondering if the first comment indicates another bug.
Comment 7 adrianknight89 2016-11-30 07:57:05 UTC
See https://github.com/xamarin/Xamarin.Forms/pull/578
Comment 8 Rui Marinho 2017-01-03 11:35:41 UTC
Should be fixed in 2.3.4-pre2