Bug 43734 - [Android AppCompat] TabbedPage tab title cannot be updated
Summary: [Android AppCompat] TabbedPage tab title cannot be updated
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-08-25 08:18 UTC by Jani Lirkki
Modified: 2016-11-25 06:14 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample app for reproducing title update bug on Android (49.24 KB, application/x-zip-compressed)
2016-08-25 08:18 UTC, Jani Lirkki
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jani Lirkki 2016-08-25 08:18:55 UTC
Created attachment 17209 [details]
Sample app for reproducing title update bug on Android

### Overview
On Android with AppCompat the TabbedPage tab titles cannot be updated.

### Steps to Reproduce
1. Run the attached repro project
2. Press the "Change title" button embedded within the tab.

### Expected Results
Tab titles are updated. In the sample app the first tab title should change to "Hello" and second tab title should change to "World".

### Actual Results
Tab titles are not updated.

### Testing Info
Reproduced using Xamarin forms 2.3.2.118-pre1.
The bug was not reproducible until AppCompat was added by following these instructions: https://developer.xamarin.com/guides/xamarin-forms/platform-features/android/appcompat/
Comment 1 Jimmy [MSFT] 2016-08-26 20:45:31 UTC
Marking as CONFIRMED since I am able to reproduce the issue with the attached sample project and repro steps.
Comment 3 Jani Lirkki 2016-09-19 07:55:09 UTC
Still reproducible in Xamarin Forms version 2.3.3.152-pre2.
Comment 4 adrianknight89 2016-10-01 19:44:15 UTC
What is the behavior on iOS and UWP?
Comment 5 adrianknight89 2016-10-01 21:02:43 UTC
See https://github.com/xamarin/Xamarin.Forms/pull/410
Comment 6 Rui Marinho 2016-10-04 15:06:43 UTC
Should be fixed in 2.3.4-pre1
Comment 7 Parmendra Kumar 2016-11-25 06:14:29 UTC
I have checked this issue with 2.3.4-pre1 and observed that this issue has been fixed.


Hence closing this issue.