Bug 43675 - New "run configurations" menu means we can't see which emulator is selected
Summary: New "run configurations" menu means we can't see which emulator is selected
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Shell (show other bugs)
Version: Trunk
Hardware: Macintosh Mac OS
: --- critical
Target Milestone: (C8SR1)
Assignee: Marius Ungureanu
URL:
: 44390 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-23 17:09 UTC by Nate Cook
Modified: 2016-10-06 22:18 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Nate Cook 2016-08-23 17:09:21 UTC
# Steps to reproduce
Open a project with a project name that is 21 characters long, and a build configuration that is 14 characters long.

# Expected behavior
I can see the name of the emulator, or at least the first five or six characters of the selected emulator, in the dropdown at the top.

# Actual behavior
The new menu design, which now includes a dropdown for "Run Configuration", is so long that it doesn't leave any room for the emulator name. That means one has to click the name of the dropdown just to see which emulator they have selected, which is very annoying.
Comment 1 Marius Ungureanu 2016-09-19 11:33:00 UTC
A fix wlil be deployed soon. The problem is that there is not enough space to render all the items in the widget, due to NSToolbar's layout constraints.

Added an implementation which prefers the last selected item and renders it if there is enough space in the widget.
Comment 2 xamarin-release-manager 2016-09-19 13:57:16 UTC
Fixed in version 6.1.1.11 (cycle8-sr0)

Author: Marius Ungureanu
Commit: 7477079463be595d858d81f35be910074aadcc78 (mono/monodevelop)
Comment 3 xamarin-release-manager 2016-09-19 13:57:30 UTC
Fixed in version 6.1.2.6 (cycle8)

Author: Marius Ungureanu
Commit: 434b66350890c38a0df27eb261ff3f7fa754f768 (mono/monodevelop)
Comment 4 Mohit Kheterpal 2016-09-19 13:59:25 UTC
I have checked this issue and observed that this issue has been fixed as shown in screencast : http://www.screencast.com/t/POBlVd1CqcH

Using non-release branch : i.e. XamarinStudio-6.1.1.9_94cb9501.dmg 

Hence closing this issue.

thanks
Comment 5 Mohit Kheterpal 2016-09-19 15:40:21 UTC
I have checked this issue with latest build of C8SR0 and observed that fix for this issue has been merged as shown in screencast : http://www.screencast.com/t/rzeFQVmAN

Using XamarinStudio-6.1.1.12

Hence closing this issue by marking it as verified.

thanks
Comment 6 Marius Ungureanu 2016-09-23 00:04:13 UTC
*** Bug 44390 has been marked as a duplicate of this bug. ***
Comment 7 xamarin-release-manager 2016-10-06 22:18:33 UTC
Fixed in version 6.1.2.27 (cycle8)

Author: Marius Ungureanu
Commit: 7477079463be595d858d81f35be910074aadcc78 (mono/monodevelop)